x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Dark colors are displayed brighter and greyer.

I've seen other people complain about this as well in #unrealengine irc. This picture explains it all:

alt text

Its a blueish black, and even bluer and brighter colors that are darker than that preview appear like that as well...

alt text

alt text

Ive turned off every kind of post processing including tone mapping and it makes no difference. The material itself is unlit.

Product Version: Not Selected
Tags:
more ▼

asked Aug 05 '14 at 04:52 PM in Bug Reports

avatar image

xC0DEB10C
298 12 117 40

avatar image ChristopherPC64 Aug 05 '14 at 05:21 PM

Hey that picture didn't post can you please repost.

avatar image Adam Davis STAFF Aug 05 '14 at 05:25 PM

Hi Tingle,

Unfortunately I do not entirely understand what I am looking at. What asset are you altering the color to? How do you have the MID set up? If you are adjusting the skydome (This is my assumption as the parent does read "skydom"), does your world have a skylight that could be altering the color? Any information you can provide that will allow me to reproduce this on my end would be extremely helpful in determining whether or not this is a bug and how best to go about addressing it. Thank you!

avatar image xC0DEB10C Aug 05 '14 at 05:36 PM

Just a color in the color picker. The bottom 2 images are the color I choose in the color picker and the one the arrow is pointing to it the preview of the color I choose in the Constant3Vector which is input into the materials Emissive Color. I also divided the color through 1 to get a 0-1 color like to have a non-glowing emissive. I also have the same issue with any color anywhere. In c++ I read the color from a curve and print it out, the color values are correctly printed out but the one that is displayed is brighter.

avatar image Adam Davis STAFF Aug 05 '14 at 05:39 PM

Could I see a screenshot of your material? As of yet the color picker and the preview seem to be working on my end. Also, what version of the editor are you currently using?

avatar image xC0DEB10C Aug 05 '14 at 06:00 PM

4.3. http://s3.postimg.org/x05wqiylt/Untitled_1.jpg

I'm in irc.freenode.net #unrealengine as Tingle0x5313

avatar image Adam Davis STAFF Aug 05 '14 at 06:14 PM

Does the same thing occur when you use just a flat 3 vector without dividing? Also, try adding a constant 3 vector param with the same value as the emissive to your base color. See if that alters the output.

avatar image xC0DEB10C Aug 05 '14 at 06:28 PM

Same thing. The only way I can get the correct color is by using a texture, that will display correctly. But the same color picked through the color picker is the wrong result as shown above.

avatar image Adam Davis STAFF Aug 05 '14 at 06:44 PM

How does the material look with the sRGB channel checkbox set to true?

avatar image xC0DEB10C Aug 05 '14 at 06:47 PM

Ah thats the problem, the color is displayed as sRGB even tho its not checked but I cant find a sRGB option on the material itsself to turn it off.

avatar image Adam Davis STAFF Aug 05 '14 at 06:54 PM

Hi Tingle,

After playing around with this a bit more, I was able to reproduce this and will attach this conversation and my own findings to a bug report for assessment. Thank you and have a great day!

avatar image xC0DEB10C Aug 05 '14 at 06:55 PM

Wait, can't I turn off sRGB some how?

avatar image Adam Davis STAFF Aug 05 '14 at 08:55 PM

HI Tingle,

Gamma correction is used to saturate the colors of a texture to help it look correct in lighting. It does darken the color of the material as well, however it's primary role is to provide a rich, full look to the color within the texture. It should never be used for normal maps, as the color saturation will cause light to bounce in unintended ways.

avatar image nickpetersonfx Aug 05 '14 at 09:16 PM

Be sure to check your exposure settings too. That can cause all sorts of headaches when you aren't expecting it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I did a bit more research, and it turns out that the sRGB channel should be set to true, Specifically on this documentation page: https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/Properties/index.html it discusses the purpose behind the sRGB channel and its' effects. As such it seems that the channel is working correctly, and the reason there is no significant difference between the constant three vectors is that this is meant specifically for textures and their gamma correction. This is not precisely true, however, if your color setting is done in c++, did you set your color in the editor or in c++ specifically?

more ▼

answered Aug 05 '14 at 07:27 PM

avatar image xC0DEB10C Aug 05 '14 at 07:29 PM

Im setting the color in the material through a vector/color like in the screens, hence the color picker. And in the vector there is the sRGB option, but turning it off has no effect.

avatar image Adam Davis STAFF Aug 05 '14 at 07:34 PM

That's what is intended. Because it is not being plugged into a texture, the constant 3 vector does not require gamma correction, therefore it isn't going to have an effect. If you were plugging the three vector into a texture, it should work properly.

avatar image xC0DEB10C Aug 05 '14 at 07:35 PM

Ok thanks.

What is gamma correction for anyway? It just goofs up colors...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question