x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Animation Blueprint is stopping character movement on a specific input

Hi all,

So I know how to work with Animation Blueprints, but this has me completely stuck. I have my character blueprint set to have an input for Combat Mode. When the input is pressed, the character plays a draw sword animation and goes into idle for that specific combat mode. However, when in this mode the character cannot move at all. He is frozen in place no matter what input I give except the sheath sword input.

This only happens for the movement when a sword is drawn, movement still works when I sprint.

I am using Mixamo animations for the movement as placeholders since mine still need work and I used the marketplace mixamo retargeter to get the animations have the right rig. I know this cannot be the issue because I have a basic walk for the character (which is mixamo as well) working perfectly for the character. The problem seems to be with the Combat Mode activation. This, for some odd reason, prevents him from moving all together. I created an output string to show his speed, when not in combat mode he gets to speed 160 which was the one I set, but in combat mode he stays at 0. Here are the things I tried to solve the issue: 1. Replaceing the blendspace with the one I know is working. I swapped out the blendspace, made the connection to the draw sword animation. Now when combat mode is activated he plays the drawSword anim, goes to the basic idle (but still in combat) and still does not move. 2. Replace the animations within the 1dD Blendspace with other animations, nothing. 3. Swapping around connections within the Animation Blueprint. Still frozen 4. Made an event begin play to have him start the game in combat mode, still frozen. Below are some images to show my blueprints. if anyone can help me solve this I would be extremely grateful. My guess is that it could be a bug with engine version 4.19, but I am not sure.

Thanks, Nathaniel Hill

[1]: /storage/temp/242562-warriorwalk-node.png

Product Version: UE 4.19
Tags:
more ▼

asked May 29 '18 at 02:17 PM in Blueprint Scripting

avatar image

Falthar
6 2 2

avatar image Falthar May 29 '18 at 08:50 PM

Alright, so this is really weird and I think it is a bug with Unreal Engine 4.19.2. When Root Motion is enables on an animation it prevents the animation from working. This is what was preventing my character from moving (picking up speed). If anyone can confirm this is a bug that would be great.

avatar image ChibiPC Mar 21 '19 at 04:41 PM

I ran in to this same issue. i literally dismantled and unlinked every. single. link in both my animation blueprint and the characterBP. No luck. was about to start from scratch since it stuck with the animation BP no matter what i did. found this post, instant fix. seriously why.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Solved the issue. For some reason when selecting enable root motion from everything this prevents root motions animations from playing. I am not sure why this happens so if anyone has an explanation that would be great.

more ▼

answered May 29 '18 at 08:59 PM

avatar image

Falthar
6 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question