x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Distribution Vector Particle Parameter: Color clamps to 0,0,0 - 1,1,1

I am trying to edit a particle's color and lerp it over a period of a second. I am using colors at are over 1,1,1 so they have emission and glow. However, when I try to change the color through the lerp node, the blueprint seems to clamp it to 1,1,1, or just plain white. I've attached my Cascade setup, the section of my BP where I change the color, and the Parameter options in the blueprint. I'd be happy to provide any more information. Thanks in advance!

alt text alt text alt text

Product Version: UE 4.19
Tags:
more ▼

asked May 29 '18 at 05:57 PM in Blueprint Scripting

avatar image

SamelCamel
1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This effect of clamping the bloom of emissives happens to me on mobile devices or in splitscreen, and this is by design (it was Epic's way of fixing a bug where blooms would artifact between split screens). Mobile device problem is probably just because I have a really unpowerful device. I am not sure if that's the reason it's happening to you though, and I don't know if it clamps the parameter values or just the render (I think it's just the render).

more ▼

answered May 30 '18 at 04:55 PM

avatar image

mightyenigma
3.8k 18 24 21

avatar image SamelCamel May 30 '18 at 08:23 PM

It clamps the actual parameter. The value is automatically reset to 1,1,1 when set manually.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm not sure why it does that, or if a different Distribution type might allow you to do what you want, but here's a workaround:

Have your parameter vector represent percentage(s), and in your material graph, simply multiply the maximum value you want it to be able to reach, by that value (between 0.0 and 1.0), and you should be able to get the same effect as if the parameter allowed a range of values up to that maximum value.

more ▼

answered May 30 '18 at 09:49 PM

avatar image

mightyenigma
3.8k 18 24 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question