x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Source-compiled 4.19 remote iOS build can't init

Hi! I`m using a source-compiled UE 4.19.2 and for the life of me, no matter what I try, this always happens and the build does not start.

PackagingResults: Error: Failed to run init commands on 192.168.12.103 PackagingResults: Error: Failed to initialize a connection to the Remote Server 192.168.12.103 PackagingResults: Error: System.FormatException: Input string was not in a correct format. PackagingResults: Error: Command failed (Result:5): F:\UnrealEngine-4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe SpyClash IOS Development -Project=F:\UnrealEngineProjects\SpyClash\SpyClash.uproject F:\UnrealEngineProjects\SpyClash\SpyClash.uproject -NoUBTMakefiles -remoteini="F:\UnrealEngineProjects\SpyClash" -skipdeploy -noxge -generatemanifest -NoHotR eload. See logfile for details: 'UnrealBuildTool-2018.05.30-16.58.32.txt' PackagingResults: Error: Unknown Error

Also to note!: Whenever I generate my SSH key in the editor, it generates it ok, but it also reports this exact same line as in the log: key_read: uudecode AAAAB3NzaC1yc2EAAAADAQABAAABAQCnjZFh1daCKDTnToj0hHc/WC268ngSVCvFMHh8njyJz5oGnAAcb0lrqRArsUxCYF3CBNTtz7JVOTDAPZAfvcTVHF4rRBCVMI8gewRgNITO1nTpGKhLTr0uHLXB1nwc2Mrxtd/m/fxTfCatjPz4DGWvMoWeKkyuVA/HBvf2TeqyTZiQwY5qlhqxTNNOlxhcDC21X9L+kCZRo/bdF5rI86Suy89I2eSDPW+lhkeNHl9qGnxDv5PPhNJYc3Xo9/tv+0PvjkATuwUkz8faNGAKGFmZF/iXIIogR7LDOGkj+rnwKae+GOF49ooMbnhPVX4kIWsnX7JtuZmVEUIki/A7pHXRgitlab.com,52.167.219.168 ecdsa-sha2-nistp256 AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBFSMqzJeV9rUzU4kWitGjeR4PWSa29SPqJ1fVkhtj3Hw9xjLVXVYrU9QlYWrOLXBpQ6KWjbjTDTdDkoohFzgbEY= failed

Even after I have deleted the key and nothing is selected, when I open the SSH generation command, the first step reports it as failed and same in the third step. What is it reporting and why?

The project did build remotely just fine when I was using the retail version. I tried creating a new certificate and went through the whole remote build setup process as described here as it seems the most recent post regarding the subject. Most others still deal with some manual delta copies and what not, which are irrelevant for the version I`m using: https://forums.unrealengine.com/development-discussion/ios-development/1360247-4-17-2-ios-packaging-error

I've tried moving the .ssh file to my project folder, I've tried overwriting its` security permissions and I've tested the connection to the remote mac through the command window and the connection is there so it must be something on the UE4 side. All of my devices, my windows pc and my mac are connected to the same router which hosts our own local network.

Last time my project succeeded on a remote mac for iOS was when it was demo-ed in the retail version of the engine, but I switched to source because of the need for a dedicated server. Not sure if that is relevant, but it might be. The project packages just fine for Android and Windows and the server builds and works too.

Product Version: UE Github Master branch
Tags:
more ▼

asked May 30 '18 at 02:31 PM in Packaging & Deployment

avatar image

Skalbe
6 2 3

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question