x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Disable smoothing in Unreal?

Hey there,

I'm trying to import a character model I made using Blender into Unreal Engine. In Blender, the mesh is not being smoothed, because it is supposed to actively "look" low-poly.

When being imported into UE4, the mesh appears smoothed, with a look similar to the one rendered by Blender when the shading mode is set to "Smooth" instead of "Flat".

The problem apparently only occurs when dealing with Skeleton Meshes, I never had any problems when importing Static Meshes.

Is there a way to disable this effect? Or is there any box I should have checked or unchecked?

The export seems fine, importing the mesh into other 3D software works flawlessly.

I attached two screenshots that show the same mesh in Blender and Unreal Editor.

Thanks a lot for any answers

MrPhil

Blender:

alt text

Unreal:

alt text

Product Version: Not Selected
Tags:
more ▼

asked Aug 05 '14 at 09:43 PM in Using UE4

avatar image

MrPhil
63 8 9 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

What is Normals set to in import dialog window? Set it to Import tangents and normals if it is set to Calculate and see if it helps.

more ▼

answered Aug 05 '14 at 10:03 PM

avatar image

Jacky
16.7k 671 167 674

avatar image MrPhil Aug 05 '14 at 10:07 PM

Thanks a lot - that works perfectly! :)

avatar image piXelicidio Feb 16 '16 at 09:47 PM

For me nothing work, tried every combination and every time the character is smoothed, this is driving me crazy from 2 days in a row without luck.

My model only has morph targets, no bones, but I need to import as skeletal mesh to use the animations. When imported as static mesh it works, well without the anoying auto-smooth.

ver 4.10.2

avatar image Jacky Feb 16 '16 at 10:03 PM

Which program are you exporting from and what are your export settings?

avatar image piXelicidio Feb 16 '16 at 10:02 PM

Found something, the problem become interesting, when the morphing value is 0 my character look non-smoothed as i want.

When i change the morph target value the smoothing start to appears, see the following two images:

alt text alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question