x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Don't know why crouch animation is not working.

all the blueprints seems okay but the crouch animation is not working, dont know why.

Product Version: UE 4.19
Tags:
crouch.jpg (30.8 kB)
crouch2.jpg (40.4 kB)
crouch-3.jpg (35.8 kB)
crouch4.jpg (34.4 kB)
crouch5.jpg (31.3 kB)
more ▼

asked Jun 02 '18 at 08:34 AM in Using UE4

avatar image

Azouf
11 1 6

avatar image Brylos Jun 02 '18 at 10:26 AM

From the input action of pressing the crouch button, make sure it's actually setting crouch to true when pressed and set it to false when released. So just add it onto the crouch and uncrouch you already have.

avatar image Azouf Jun 02 '18 at 11:28 AM

alt text

i fixed it but the animation seems odd and not in place where it should be

capture.jpg (30.3 kB)
avatar image Brylos Jun 02 '18 at 12:38 PM

The center of your mesh is at 0,0,0 in whatever 3d modeling program you're using so your hips are at 0,0,0 when it should be your feet that are at 0,0,0. This means that whatever animation you play, it is centered from the hips and not the feet which is what is resulting in it looking like you're floating. To fix this, edit the skeletal mesh in your 3d modeling program by moving it upward so the feet are at 0 on the height axis. As a result you'll also have to edit the crouch animation so it has the correct height.

avatar image Koppa Jun 02 '18 at 01:10 PM

have you enabled root motion on the crouch animation?

avatar image Azouf Jun 02 '18 at 04:19 PM

yes and it becomes worse

avatar image SenToRious Jun 03 '18 at 12:37 AM

You can edit the animation in UE4, open the animation asset (make a backup first by selecting the animation and CTRL+W) pause the animation and go at the beginning, select the rootbone or the one after it (depending on your skeleton) in the Skeleon tree tab in the left, then change the Z location finally press the + button (Key) and save. alt text

key.png (225.7 kB)
avatar image Bater Oct 15 '18 at 05:50 AM

I have the same issue and the solution was to do a translation retargeting to animation instead of the skeleton, in the skeleton itself but this will kill every root motion animation as the character capsule will not move with root motion animations and you will see them jumping out of the capsule boundaries also you will find many other artefacts in other unrelated animations

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question