x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

What does "bad name index -1/43" error mean in the context of a failed packaging attempt?

The line in the output log with this error is:

UATHelper: Packaging (Windows (64-bit)): LogInit: Display: LogLinker: Error: Bad name index -1/43

Thanks!

Product Version: UE 4.19
Tags:
more ▼

asked Jun 04 '18 at 02:05 PM in Packaging & Deployment

avatar image

cherking
11 2 3 8

avatar image BreakMaker Jun 28 '18 at 08:49 PM

Hi there,

Have you found a solution? I am experiencing a similar issue!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

For anyone show still has this issue. You can find the asset causing this by building the engine from source and adding breakpoints here and here. Loading the project then already triggers the breakpoints. In the stacktrace you can then find the call to UObject::Serialize(FArchive & Ar) which will reveal the name of the asset that is causing the issue: alt text In my case BT_Unit_Default. Which is a Behavior tree. I made a new Behavior tree and copied all the nodes into it and that fixed the issue. I guess it was some internal error in the behavior tree.

more ▼

answered Aug 25 '18 at 05:08 AM

avatar image

erikdubbelboer
366 3 4 7

avatar image BreakMaker Aug 27 '18 at 07:58 PM

Thanks, very useful. I tried to see but how do I build from source code? The project is Blueprint based, can I compile it from code?

What I usually did was just "attach to process" after starting loading up the project.

avatar image erikdubbelboer Aug 28 '18 at 06:01 AM

I have no idea if "attach to process" works, I have never tried that. Are the debug symbols available in their normal installation? How to build the engin can be found here: https://docs.unrealengine.com/en-us/Programming/Development/BuildingUnrealEngine

avatar image BreakMaker Aug 28 '18 at 06:17 AM

Thanks, for the info.I will definitely try this next time when I have an issue.

Yes, you can optionally install the debug symbols even after having set up the engine. In the launcher where your installed versions are, just click on the triangle and there is a drop down menu.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question