x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal incompatible with Visual Studio 2017 15.5.2

I am using UE4 4.18 with Visual Studio 2017.

Until yesterday, it was working fine. I could open projects and compile without problems.

I wake up this morning and suddenly it isn't working, and I receive this error:

alt text

When I click OK, my project looks like this:

alt text

I do note there was an update to Visual Studio overnight, since Visual Studio asked me to restart. The current version is 15.5.2.

The project migration report says:

alt text

I updated Visual Studio through control panel, but that hasn't solved the problem.

Has anyone had this problem? Is there a fix? I don't really want to have to update to UE 4.19 unless I really have to.

Product Version: UE 4.18
Tags:
unrealerror.png (20.8 kB)
unreal2.png (7.6 kB)
unreal3.png (20.6 kB)
more ▼

asked Jun 06 '18 at 09:58 PM in C++ Programming

avatar image

DeliciousWhales
21 2 3 4

avatar image DeliciousWhales Jun 07 '18 at 02:19 AM

P.S. I have re-generated my visual studio solutions from the uproject file, which doesn't help.

avatar image DeliciousWhales Jun 07 '18 at 09:27 AM

Well I ran the VS updater again and updated to 15.7.3, re-installed the UE4 installer, created a new C++ project and it seems to load OK into Visual Studio.

But I still can't load the existing project, it just shows as incompatible still.

avatar image MPJansen Jun 07 '18 at 06:17 PM

Having the very same issues here.

Happens for 4.19 and 4.18 for me on vs version 15.7.3

avatar image DeliciousWhales Jun 08 '18 at 10:26 AM

I did manage to get it working again, thought it seems a bit unreliable. I loaded my project through the launcher (instead of opening uproject from explorer), regenerated the solution, loaded into visual studio, the right clicked on the project and selected reload. Then it came up.

But if I load uproject from explorer or load the visual studio solution file directly, it breaks. This worked for one project, another one I couldn't even load at all because it kept trying to recompile and failing on load so I couldn't even open it.

avatar image MPJansen Jun 09 '18 at 10:45 AM

I must've reinstalled visual studio 3 times, none of which worked. Finally I tried this: https://stackoverflow.com/questions/45738512/could-not-load-type-microsoft-build-framework-sdkreference-on-project-open-in

Seems this is rather a visual studio problem where some cache could get broken.

And then it worked after a reboot.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This is a pretty niche answer, but I will provide it here in case it helps anyone. I had both v140 (2015) and v141 (2017) build tools installed for Visual Studio. The reason was that I sometimes had to use v140 build tools for stuff such as setting up amazon gamelift. However, I wanted to continue building my Unreal projects using v141 so I deleted the v140 tools. What I forgot to do was delete the VCTargetsPath variable that I set to the location of the v140 tools in my environment variables.

alt text

After doing so, I had to do some other things such as re-generating the visual studio files as well as cleaning the project before building again. Note that you may still have to right-click the project files and select "Reload Project".

capture.png (12.7 kB)
more ▼

answered Mar 09 '19 at 10:37 PM

avatar image

DaneBrick
33 9 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question