x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[UMG] Tooltips widget picker doesn't function at all, manual set tooltip widget spawn but not visible at screenspace.

Hello guys, I have multiple questions to ask the community regarding tooltips usage.

I remember back in 4.16/4.17 the tooltips widget picker is not grey out and able to select, sorta like how instanced pointer work, and now it is gone on 4.19.2.

alt text

Secondly, I have a problem when I hovered over them, as they are not visually there, but widget reflector show they are spawned and visible, I am able to pull widget exposed data from each of them.

Here is my attempt to spawn to make them appear, none of them make it show:

(Just in case being questioned my spawning method wasn't detail) - Create widget in function binding and return it everytime. - Create widget in construct and return that variable in function binding. (No multiple spawns) - Discard function binding, use "SetTooltip" widget node

alt text In every case, I also print the content using widget tick like this. alt text

The result is that whenever I hovered on top of the widget, the tick will pull the data correctly, but they just not appear below the mouse. I also try to force the position of the widget by using SetPositionInViewport at 0,0, but it didn't show.

I also tried to use very big desired size with position together and hopefully see the edge of them, but nothing has shown so far. Meanwhile, widget reflector gives me both their desired size and position is 0,0 even if I had forced them to be as large as possible.

alt textalt text

Also, I tried to query the "Tooltip Widget" as the variable from engine, it printed null for me. Same goes to "Tooltip Text", even if I setup "huehuehue" but I also print it as no value.

Didn't anyone facing this issue?

Product Version: UE 4.19
Tags:
more ▼

asked Jun 08 '18 at 04:50 PM in Everything Else

avatar image

Hyrex93
182 1 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Issue solved :

  1. GetDesiredSize is a cache rather than the actual parameter to manipulate

  2. Tooltip seems unable to SetDesiredSize(), must use size to content within the body. If one wanna make the widget generic, he had to do it on the brush image size instead.

  3. Tooltip Widget and TooltipText being null because it was queried on wrong location.

more ▼

answered Jun 08 '18 at 06:36 PM

avatar image

Hyrex93
182 1 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question