x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Google VR motion controller teleport [SOLVED]

Hello everybody. I buyed a Lenovo Mirage with a DayDream motion controller. I followed the tutorials for setting up the DayDream motion controller and works fine, the controller is visualized in the space and moves how it should. The problem is when I try to use the teleportation. I use the BP_MotionController blueprint given in the VR template as I used to do with the HTC Vive( and back then it worked ) but nothing happens, excluding the hand mesh that follows correctly the controller. Any thought could help! Apologies for my bad English!

Product Version: UE 4.19
Tags:
more ▼

asked Jun 13 '18 at 01:01 PM in VR

avatar image

AnvixStuds
1 1 2

avatar image BladeMaster Jun 13 '18 at 03:37 PM

Do you have Navmesh in your level? The VR teleport does not work without navmesh.

avatar image AnvixStuds Jun 14 '18 at 06:31 AM

Yes, it is the unreal standard VR template and it has already navigation meshes.

avatar image IndieGameCove Jun 14 '18 at 07:02 AM

I'd start by checking the inputs. Can you get the button you're using for teleporting to do anything? You could use replace the teleport logic with a play sound node to debug if the event even starts to execute.

avatar image AnvixStuds Jun 14 '18 at 10:49 AM

I tried and in fact the input was wrong. The BP needed many changes but it was nothing too complicated and now everything works! thank you!

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question