x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to properly package a plugin with dependency to other modules

Hey,

I'm trying to package my plugin that depends on another module. My error looks as follows :

 I:\Epic Games\UE_4.17\Engine\Source\Editor/AnimationModifiers/Public/AnimationBlueprintLibrary.h(9): fatal error C1083: Cannot open include file: 'AnimationBlueprintLibrary.generated.h': No such file or directory


I'm using functions from the AnimationBlueprintLibrary and therefore I included it in the .cpp file that uses it.

 #.cpp
 #include "Editor/AnimationModifiers/Public/AnimationBlueprintLibrary.h"

Also, I added the corresponding module to my modules

    PublicDependencyModuleNames.AddRange(
             new string[]
             {
                 "Core",
                 "AnimationModifiers",
             }
             );

I'm using binary version of 4.17 for win10 with VS2017. The plugin itself compiles fine and works as intended.

What's the mistake here?

Product Version: UE 4.17
Tags:
more ▼

asked Jun 18 '18 at 07:28 PM in C++ Programming

avatar image

kosmopilot
17 4 6 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You also need to add a "Plugins" section to your .uplugin file.

Something like:

 ...
 "Modules": [
         {
             "Name": "YourPlugin",
             "Type": "Runtime",
             "LoadingPhase": "PreDefault"
         }
     ],
     "Plugins": [
         {
             "Name": "AnimationBlueprintLibrary",
             "Enabled": true
         }
     ]
more ▼

answered Jun 19 '18 at 01:26 PM

avatar image

Jawdy
361 2 4 6

avatar image kosmopilot Jun 19 '18 at 05:19 PM

I'm afraid the AnimationBlueprintLibrary isn't a plugin, neither could I find a plugin that relates to it :/

avatar image Jawdy Jun 19 '18 at 06:54 PM

Ah, I see.

OK, so I'd recently solved linking/referencing a Plugin within another Plugin, but I've also had what you're now hitting (I think/hope!).

Try adding the path to the includes in your .uplugin descriptor:

 PublicIncludePaths.AddRange( new string[] { "AnimationModifiers/Public" } );

Make sure to use the correct path, as what I've written above might not be exact! Like as you've done in your #include.

avatar image kosmopilot Jun 19 '18 at 07:39 PM

I'm afraid I already tried that, should've mentioned that.

 PublicIncludePaths.AddRange(
             new string[] {
                 "Editor/AnimationModifiers/Public"
             }
             );

As well as trying to add the private include path. Can you reproduce the error when adding the AnimationBlueprintLibrary to your plugin and packaging it?

avatar image Jawdy Jun 20 '18 at 06:47 AM

How are you packaging your plugin? Are you following instructions like this Wiki, or something else?

Also, what version of UE4 are you running? I spotted this AnswerHub post with something similar, but was fixed in 4.19.

avatar image kosmopilot Jun 20 '18 at 05:29 PM

The instructions from Rama are the same as when you click "package" in the plugin window ( tested it), it runs the automation tool. I'm running 4.17. Thank you for your patience and help :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question