x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot see objects after hitting "play"

This question comes from my 8 year old son...

I'm in the level editor and after adding a range of objects through the content browser. I can then explore and wonder the level. Then all of a sudden any new object that I place in the editor aren't displayed when selecting "play". I see them in the preview but when entering the game, nothing.

There are no errors (from what I can see). Is this a bug or human error? This has happened a few times and he ends up deleting his level and starting again.

Any help for this frustrated 8 year old would be greatly appreciated.

Product Version: UE 4.18
Tags:
more ▼

asked Jun 19 '18 at 02:35 AM in Using UE4

avatar image

Brainz2010
1 1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

What kind of objects are those?


This could happen if the newly placed objects are simulating physics but do not have collision set up.
As soon as you start playing the level, they start falling due to gravity but the floor geometry is unable to detect and block them from sliding through it.

Assuming that your objects are actors with static meshes, Simulating Physics, Enabling Gravity and setting Collision Presets to Overlap All would replicate behaviour you're seeing; as demonstrated below:

alt text


Another case scenario is having Actor Hidden in Game flag enabled. An object like this will show up in the edit mode but not in PIE (play in editor).

capture.png (27.7 kB)
more ▼

answered Jun 19 '18 at 04:08 AM

avatar image

Everynone
12.5k 71 24 51

avatar image Brainz2010 Jun 19 '18 at 05:50 PM

Thanks for the reply.

It could be any object. For example, there could already be 30 objects in place (houses, walls, doors, chairs, balls etc). Then after a certain point, you try add an additional object (the most recent example would be a cereal box) and it won't appear in the PIE but viewable in edit mode.

I'll try the suggestions you have mentioned!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question