x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UDataAsset not showing anything in editor

Here's my class:

 #pragma once
 
 #include "Engine/DataAsset.h"
 #include "TestDataAsset.generated.h"
 
 /**
  * 
  */
 UCLASS(BlueprintType)
 class TICTACTOE_API UTestDataAsset : public UDataAsset
 {
     GENERATED_UCLASS_BODY()
 
 public:
     UPROPERTY(EditAnywhere, Category = "TestStuff")
         int32 SomeInt;
 
     UPROPERTY(EditAnywhere, Category = "TestStuff")
         uint32 SomeUnsignedInt;
 
     UPROPERTY(EditAnywhere, Category = "AnotherCateogry")
         float SomeFloat;
 
     UPROPERTY(EditAnywhere, Category = "AnotherCategory")
         FVector SomeVector;
 
     UPROPERTY(EditAnywhere, Category = "TestStuff")
         FColor SomeColor;
 };


I can create an asset of this type by right clicking in the Content Browser, selecting "Miscellaneous > Data Asset...", then selecting "TestDataAsset" from the dropdown.

If I then double click on that asset, it opens the "Generic Asset Editor" but it's totally blank: blank asset editor

How do I edit these assets? Do I have to make my own editor UI?

I noticed that the data was editable in the Property Matrix view but that interface seems very clunky compared to the Details Pane for editing regular stuff in the scene.

Product Version: Not Selected
Tags:
more ▼

asked Aug 06 '14 at 10:28 PM in Using UE4

avatar image

ryani
57 9 14 30

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After much stepping through the debugger, I found that there was a details tab but it was closed. I then noticed this entry in one of the menus:

alt text

Checking that element fixed it. I did Save Layout followed by Reset Layout... and everything seems OK now.

I'm not sure how I messed it up, but it works now.

more ▼

answered Aug 07 '14 at 12:56 AM

avatar image

ryani
57 9 14 30

avatar image coolk77 Sep 09 '18 at 10:44 AM

I cant find the details option. My version is 4.20alt text

ssa.png (36.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question