x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[iOS] Certificate Expired warning

I always get this message below when delivering our app with the application loader.
My developer and distribution provision and certificate is valid in the project settings and it remote builds ok. It verifies ok with applicaiton loader as well but when I upload I get this warning.

I'm currently using unreal 4.18.3 on a windows 10 machine and Xcode 9.0 on a remote mac mini. I haven't installed any certificates to the mac mini after installing Xcode. But this WWDR certificate is valid on my system keychain and I even tried reinstall it without success. Do I need to add more certificates to the mac even tough it only warns me about this one which is installed?

I have contacted Apple support for help and to ask if I can send it in for review anyway since the app works perfectly but I guess thiss will fail the review and I wanted to ask here if anyone have similar issues.

The message: Dear Developer, We identified one or more issues with a recent delivery for your app, "Cityloop". Your delivery was successful, but you may wish to correct the following issues in your next delivery: Certificate Expired - The signing certificate "CN=Apple Worldwide Developer Relations Certification Authority, OU=Apple Worldwide Developer Relations, O=Apple Inc., C=US" with serial number 25 used to sign Cityloop.app has expired. Learn more (https://help.apple.com/xcode/mac/current/#/dev154b28f09).

Product Version: UE 4.18
Tags:
more ▼

asked Jun 20 '18 at 03:54 PM in Packaging & Deployment

avatar image

KristofferF
13 3 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

To anyone who gets this error. I solved it by installing the WWDR on my windows machine.

more ▼

answered Jun 21 '18 at 12:07 AM

avatar image

KristofferF
13 3 6 8

avatar image Will32 Jun 28 '18 at 12:59 PM

Once you install the WWDR what folder do you place it in. Do you place it in the same folder as the other Certs?

avatar image Aleksandro Sep 14 '18 at 07:10 PM

Hi there I'm struggling with the same issue. What do I Need to do?

avatar image Al Ananias Sep 30 '18 at 11:10 PM

Hi guys, same here. I downloaded the WWDR certificate and installed on my remote mac, but the guidance above says it should be installed on the windows machine (?!) - how?

avatar image tefica Oct 01 '18 at 02:05 PM

Hi, I had the same issue and solved by installing the new Apple WWDR Intermediate Certificate on my Windows Machine :

  1. Download the new Apple Cerificate at https://developer.apple.com/support/certificates/expiration/

  2. Double Click on the Certificate on your Windows Machine to open the certificate property window and click on "Install a Certificate" (set the automatic installation location)

alt text ][1]

  1. Find and Remove the Old Apple Certificate running the Windows Certificate Manager C:/WINDOWS/System32/certmgr.msc

Hope this helps ;)

certcapture.jpg (41.9 kB)
avatar image Al Ananias Oct 02 '18 at 07:12 PM

Legend! Thanks so much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question