x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Frequent error: The following modules are missing or built with a different engine version

Often this error appears after creating or modifying C++ codes. I couldn't solve. I created a lot of projects to test C++ codes and eventually it occurs again. I seriously think about stopping c++ programming. What's happening? How do I solve it?

alt text alt text alt text

Product Version: UE 4.19
Tags:
2018-06-20-1.png (197.3 kB)
2018-06-20-2.png (192.2 kB)
2018-06-20-3.png (232.4 kB)
more ▼

asked Jun 20 '18 at 06:13 PM in C++ Programming

avatar image

RHERWOLF
5 3 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You might be compiling the code while the editor is still running, your log in the second screenshot appears to indicate another program is accessing the files you are trying to write to.

You have options!

1) Use Unreal Editor's 'Compile' button to hot reload your code while it is still running.
2) Close Unreal Editor and compile the code from Visual Studio once there are no more programs accessing it.

Hopefully in the future we can get some better error messages from the engine team, but hope this helps for now!
-Spiris

more ▼

answered Jun 20 '18 at 07:57 PM

avatar image

Spiris
1.1k 41 33 76

avatar image RHERWOLF Jun 21 '18 at 01:15 AM

Thank you, closed editor works.

avatar image Rosium Aug 13 '18 at 09:44 PM

I get the same error when there are no instances of the editor open, do you have any other suggestions?

avatar image Amneri Aug 13 '18 at 10:32 PM
  1. Right click on your solution in visual studio -> clean

  2. Right click on your solution in visual studio -> regenerate

If it still doesn’t work, try to delete binaries and intermediate folders of your project and recompile it.

avatar image Rosium Aug 13 '18 at 11:42 PM

No Good, I get this error each time

2>EXEC : error : UnrealHeaderTool failed for target 'OPT20_V3Editor' (platform: Win64, module info: C:\Users\Meme\Documents\Unreal Projects\OPT20_V3 - Copy _withdeletefolders\Intermediate\Build\Win64\OPT20_V3Editor\Development\OPT20_V3Editor.uhtmanifest, exit code: OtherCompilationError (5)).

avatar image Amneri Aug 13 '18 at 11:47 PM

Have you the logs of the actual error ? This is just the result of the failed build.

avatar image Rosium Aug 14 '18 at 12:27 AM

link text

Here is the log, When I cleaned and build, i got no errors from VS_2017. but when i try to open the project, the module are still not recognized. And where the plugin modules need to be placed is still confusing, with exception to the .uproject, uplugin, Build.cs, .....all the info is there

log-001.txt (8.4 kB)
avatar image Amneri Aug 14 '18 at 01:20 AM

Plugins can be placed in “YourGame/Plugins” they will be build when you build your game, Or in “Engine/Plugins” or “Engine/Plugins/Runtime”. I personnaly build them in “MyGame/Plugins” then copy them to “Engine/Plugins”. This way they aren’t compiled and linked each time I build my game.

For your problem, make sure that all the Plugins you use are marked as enabled in your .uproject. (Edit it with notepad)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question