x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is showflag.Volumes 1 seem not working in game?

Hello guys i maybe find a problem/bug

Branch : 4.2.1 from Unreal Luncher

Build version : 4.2.1-2101290

Note that i have custom volumes classes and default one in my level and there are at default setup : not visible in game

Steps to reproduce the problem

1 I mapped the console key to open it in game : in my case on F1

2 Start Game in current viewport

3 Open the console

4 Type ShowFlag.Volumes 1.

Normally it should show volumes in the level as it said in the doc doc link

But it's not work why ?

I also tried

ShowFlag.Volumes =1

ShowFlag.Volumes = 1

ShowFlag.Volumes = "1"

No one work either.

OS : Windows 7 64 bits

Memory : 8 GB

CPU : Inter core i7

I don't know if you have enough infos, if no just let me know.

gamer08

Product Version: Not Selected
Tags:
more ▼

asked Aug 07 '14 at 12:10 AM in Bug Reports

avatar image

gamer08
266 17 17 36

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Gamer08,

There is not a flag that will enable or disable "Volumes" as a whole. The reason being is that there are different types of volumes such as Physics, Lightmass Importance, Cull Distance, and Post Processing to name a few.

The function is working properly when making the choices provided. There are a couple of things to note that may or may not have been clear in the documentation.

When using the ShowFlag."object type" (ie. ShowFlag.PostProcessing) you will need to use a 0 to disable and a 1 to enable the volume or object you are calling show flag on. The show flag is a simple toggle for 0 = false or 1 = true to whether it should be on in the viewport.

Fore Example: ShowFlag.PostProcessing 0 to disable the post processing effects.

Another thing to note as well is that this does not turn on the outline of where the bounds of the volume are located. This will only enable or disable the object you select from the list.

If you have any other questions feel free to ask! :)

Tim

more ▼

answered Aug 12 '14 at 06:13 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 876

avatar image gamer08 Aug 12 '14 at 06:34 PM

Thanks for your answer it's explain several things. Also to be honest the documentation is not always clear on certain subjects but that's ok it will improve over the time.

Thanks again for this answer,

gamer08

avatar image Tim Hobson ♦♦ STAFF Aug 12 '14 at 08:50 PM

No problem! Glad that worked out for you. There are improvements that need to be made to the documentation for some areas and we are definitely aware and making sure it's on our list to get completed. If you ever come across anything that you feel could be improved in the documentation or are not sure about you can post in our Feedback for Epic section of the Forums. We do review this information and pass it along to our documentation team. :)

Tim

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question