x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Still no prereq in packaged game ?

Hello,

It seems that the prerequisites are still not included in packaged games.

This is not something that is easy to test, so i can only have a feedback when i or one of my beta testers make a clean windows reinstall (which occurs maybe once or twice a year). So tests are rare. But one happened last week end and the tester told me the installation of my game didn't include the prereq and he had to manually download and run the UE4PrereqSetup*.exe installer again.

So could anyone please tell me how i am supposed to include the prereq in the packaged game ? This is really vital to distribute the game and seems to be not working.

For the moment here is what i do (as i was told to multiple times):

alt text

Is that not enough ? Anything else i should do ?

This is the third or fourth time i post such a question, see for example here, where it lead to an official issue that was supposed to be solved:

https://answers.unrealengine.com/questions/592814/no-more-prereq-in-packaged-game.html

Thanks

Cedric

Product Version: UE 4.19
Tags:
prereque4.jpg (18.1 kB)
more ▼

asked Jun 24 '18 at 07:25 AM in Packaging & Deployment

avatar image

uced
850 75 89 360

avatar image uced Jul 21 '18 at 08:24 AM

Polite bump, it's kind of important.

Thanks

avatar image uced Jul 30 '18 at 07:11 PM

I created a bug report.

avatar image uced Aug 01 '18 at 07:16 AM

The answer to my bug report was to open a question on the answerhub. So i'm back.

They told me that when checking "include prerequisite installer", the prereq should be located in WindowsNoEditor\Engine\Extras\Redist\en-us.

I just made another test and this directory doesn't exist in my package.

Anyone has any idea of what i can do ? I am using the project launcher to package my game, any chance of interference with the "include prerequisite installer" option ? Any config file i could search ?

Thanks

Cedric

avatar image uced Aug 01 '18 at 06:17 PM

Just in case, i found it in the DefaultGame.ini and it seems to be ok:

 IncludePrerequisites=True
 IncludeAppLocalPrerequisites=True
 [...]
 ApplocalPrerequisitesDirectory=(Path="")

avatar image uced Aug 01 '18 at 06:41 PM

I think i nailed it.

  • When packaging using the menu "file/package project" prereq are included.

  • When packaging using the project launcher, they are not included.

I did this using a new blank BP project without startercontent, test took 5 minutes.

If confirmed this means the bug is that the project launcher doesn't take the "include prereq" option into account.

I told that in my BR. If this is confirmed i'll update/answer this question if anyone bumps into this problem.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok, as suspected, the culprit is the project launcher.

This is now an official bug, i'm closing this question:

https://issues.unrealengine.com/issue/UE-62508

Cedric

more ▼

answered Aug 06 '18 at 04:11 PM

avatar image

uced
850 75 89 360

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question