x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Array of a custom Enum as output for an interface function

Hi there,

My goal is to use an array of a custom enum (types) as ouput for an interface function.

However, when I try to do this the engine gives me the following message:

Error Message:

BlueprintEditorCompileResults:Error: Error Default value '' for Types is invalid: ''' is not a valid enumerant of '''

My enum is coded in c++ like this:

UENUM(BlueprintType)

enum MyType { TP_Float UMETA(DisplayName = "Float"), TP_Int UMETA(DisplayName = "Int"), TP_String UMETA(DisplayName = "String"), TP_Bool UMETA(DisplayName = "Bool"), };

The setupt of the interface function:

alt text

Engine

Im working in UE 4.2.1

Trial and error

I did also test it with an enum which I created in the editor (content browser -> misc -> enumeration), got the same result.

Product Version: Not Selected
Tags:
more ▼

asked Aug 07 '14 at 08:59 AM in Bug Reports

avatar image

SpEXyPHe
1 2 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi SpEXyPHe,

Thank you for bringing this to our attention. I tested this in 4.2.1 and was easily able to see the behavior that you described. I also tried doing this in our latest internal build of the Engine, and the issue did not occur there. It looks like a fix for this issue has already been put in place and will be available in a future version of the Engine, though I am not sure exactly which version will contain the fix.

Have a great day!

more ▼

answered Aug 07 '14 at 08:46 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question