Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

IOS Icon (Wont change from unreal engine icon)

Hi, i'm trying to change the icon for my ios application but i keep getting the default unreal engine logo as the icon.

I have manually changed all the pictures within Document/UnrealProject/"Project"/Build/Ios/Resources/Graphics and have also imported all the pictures within the editor in ProjectSettings-->IOS but still nothing. All the icons displayed within project settings are displayed as my own personalised ones.

Product Version: UE 4.19
more ▼

asked Jun 25 '18 at 01:52 AM in Packaging & Deployment

avatar image

16 4 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I’ve found a solution to the problem but its quite long. Contact me if you need help on the subject.

more ▼

answered Jun 26 '18 at 05:35 AM

avatar image

16 4 5 7

avatar image zwsqq Jul 10 '18 at 04:51 AM

Hello, how did you change it in the end, thank you

avatar image huseyin12343 Jul 10 '18 at 01:02 PM

Hi , you need to remote build your project using a mac if you are using a pc workflow. Send me your discord or skype if you like and ill be able to help you much faster.

avatar image CreatorsHQ Jun 07 '19 at 03:31 PM

I already changed all the ios icons but they still appear even when I remote build I am using Version 4.22.2 how did you manage to do it?

avatar image huseyin12343 Jun 11 '19 at 10:41 AM

I honestly don't remember anymore. If you have discord pm me your username and i'll try give you a call when i'm free.

avatar image Barksie Jul 16 '19 at 09:06 PM

Hi - did you manage to find a solution for this? We are having the same challenge. Any insights would be hugely appreciated. Thanks

avatar image huseyin12343 Jul 16 '19 at 09:31 PM

I was stuck on this problem for months but as i said it was a long time ago and i don't really remember how i found the solution. If u can discord you can tell me the steps you are taking to re jog my memory and see if i can be of any help :)

avatar image Barksie Jul 17 '19 at 08:39 AM

That is very kind, thankyou.
Here is a summary so far on Windows.

  • A blueprint only project - with all plugins and ios icons default + the correct install of itunes + valid provisioning profiles. Launching and building a projects works perfectly.

  • Updating any of the icons in prefs (which is the same as creating in them in.../Build/Ios/Resources/Graphics folder) promps a remote build or the "itunes is not installed" and fails.

  • Also disabling any plugins (which updates the .uproject file) fails the build.

  • As a dirty hack, I have tried modifiying all the ios icons in the engine folder at the following locations

  • Engine\Binaries\IOS\Payload\UE4Game.app

  • Engine\Build\IOS\Resources\Graphics

  • Engine\Build\IOS\Resources\Assets.xcassets\AppIcon.appiconset

  • The app builds/ launches, but miraculously with the default UE logo as the icon on the ipad

This is as far as I have persued just on windows. I do have a mac available in our office for remote builds, which I suspect will be needed? But this is not something I have tried to configure yet.

Thanks again for your time + offer, and I will drop you a discord when I have the mac ready.

avatar image huseyin12343 Jul 17 '19 at 01:40 PM

Changing the images in the folders have no effect for some reason. At one point i deleted every unreal logo image i had on my pc but ue4 still managed to find it so how!

You will need a mac (with x-code) for a structured (remote) build and this will most likely sort out the icon issue as it has done with most people but did not work for me.


(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question