x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Trying to remote build on Mac from Windows any help with these errors?

Just trying to see if I can get this to work. iOS (out of the box Handheld AR template project) through 4.19.2 though I am on Windows 10. Trying to use the Remote Build options with my iMac which has XCode 9.4. Cert and Provs are valid.

I followed some of the documentation guides for this as well as this guide and even more hours throughout the forums and Answer Hub.

errors highlighted

line 14, 15,& 22

Any tips would be appreciated.

 LogPlayLevel: Completed Launch On Stage: Cooking in the editor, Time: 31.825679
 LogPlayLevel: Running AutomationTool...
 LogPlayLevel: Parsing command line: -ScriptsForProject="C:/Users/oloug/Documents/Unreal Projects/ARKitTest1/ARKitTest1.uproject" BuildCookRun -project="C:/Users/oloug/Documents/Unreal Projects/ARKitTest1/ARKitTest1.uproject" -noP4 -clientconfig=Development -serverconfig=Development -nocompile -nocompileeditor -installed -ue4exe=UE4Editor-Cmd.exe -utf8output 
 -platform=IOS -ini:Game:[/Script/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Disabled -build -map=/Game/HandheldARBP/Maps/HandheldARBlankMap -skipcook -CookInEditor -iterativecooking -compressed -iterativedeploy -stage -deploy -cmdline="/Game/HandheldARBP/Maps/HandheldARBlankMap -Messaging" -device=IOS@All_iOS_On_JAMESOLOUGHLINP -addcmdlin
 e="-SessionId=140FA2984AADC9F63349C2B10ECC550B -SessionOwner='oloug' -SessionName='Launch On Device' " -run
 LogPlayLevel: Setting up ProjectParams for C:\Users\oloug\Documents\Unreal Projects\ARKitTest1\ARKitTest1.uproject
 LogPlayLevel: ********** BUILD COMMAND STARTED **********
 LogPlayLevel: Completed Launch On Stage: Build Task, Time: 7.625801
 LogPlayLevel: Running: C:\Program Files\Epic Games\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe ARKitTest1 IOS Development -Project="C:\Users\oloug\Documents\Unreal Projects\ARKitTest1\ARKitTest1.uproject"  "C:\Users\oloug\Documents\Unreal Projects\ARKitTest1\ARKitTest1.uproject" -NoUBTMakefiles  -remoteini="C:\Users\oloug\Documents\Unreal Projects\ARK
 itTest1" -skipdeploy -ini:Game:[/Script/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Disabled -noxge -generatemanifest -NoHotReload
 LogPlayLevel:   Picking the default remote server 192.168.0.13
 LogPlayLevel:   Doing date +"%s" && sysctl hw.memsize | awk '{print $2}' && sysctl hw.logicalcpu | awk '{print $2}'
 LogPlayLevel:   Execute took 00:00:12.6383469
 LogPlayLevel:   ERROR: Failed to run init commands on 192.168.0.13. Output =
 LogPlayLevel:   ERROR: Failed to initialize a connection to the Remote Server 192.168.0.13
 LogPlayLevel:   Doing xcode-select --print-path
 LogPlayLevel:   Execute took 00:00:04.8720259
 LogPlayLevel:   Compiling with non-standard Xcode (xcode-select): /
 LogPlayLevel:   Doing ls /Platforms/iPhoneOS.platform/Developer/SDKs
 LogPlayLevel:   Execute took 00:00:11.9717807
 LogPlayLevel:   Compiling with iPhoneOS SDK  on Mac 192.168.0.13
 LogPlayLevel:   ERROR: System.FormatException: Input string was not in a correct format.
 LogPlayLevel:             at System.Number.ParseSingle(String value, NumberStyles options, NumberFormatInfo numfmt)
 LogPlayLevel:             at System.Single.Parse(String s, IFormatProvider provider)
 LogPlayLevel:             at UnrealBuildTool.IOSToolChainSettings..ctor(String DevicePlatformName, String SimulatorPlatformName)
 LogPlayLevel:             at UnrealBuildTool.IOSToolChainSettings..ctor()
 LogPlayLevel:             at UnrealBuildTool.IOSToolChain.<>c.<.ctor>b__1_0()
 LogPlayLevel:             at System.Lazy`1.CreateValue()
 LogPlayLevel:             at System.Lazy`1.LazyInitValue()
 LogPlayLevel:             at UnrealBuildTool.IOSToolChain.ModifyBuildProducts(ReadOnlyTargetRules Target, UEBuildBinary Binary, List`1 Libraries, List`1 BundleResources, Dictionary`2 BuildProducts)
 LogPlayLevel:             at UnrealBuildTool.UEBuildBinary.GetBuildProducts(ReadOnlyTargetRules Target, UEToolChain ToolChain, Dictionary`2 BuildProducts, Boolean bCreateDebugInfo)
 LogPlayLevel:             at UnrealBuildTool.UEBuildTarget.PrepareReceipts(UEToolChain ToolChain, Boolean bCreateDebugInfo, EHotReload HotReload)
 LogPlayLevel:             at UnrealBuildTool.UEBuildTarget.Build(BuildConfiguration BuildConfiguration, CPPHeaders Headers, List`1 OutputItems, List`1 UObjectModules, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph, EHotReload HotReload)
 LogPlayLevel:             at UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String[] Arguments, FileReference ProjectFile, Boolean bCatchExceptions)
 LogPlayLevel: Took 31.7582804s to run UnrealBuildTool.exe, ExitCode=5
 LogPlayLevel: ERROR: Command failed (Result:5): C:\Program Files\Epic Games\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe ARKitTest1 IOS Development -Project="C:\Users\oloug\Documents\Unreal Projects\ARKitTest1\ARKitTest1.uproject"  "C:\Users\oloug\Documents\Unreal Projects\ARKitTest1\ARKitTest1.uproject" -NoUBTMakefiles  -remoteini="C:\Users\oloug\Docu
 ments\Unreal Projects\ARKitTest1" -skipdeploy -ini:Game:[/Script/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Disabled -noxge -generatemanifest -NoHotReload. See logfile for details: 'UnrealBuildTool-2018.06.28-18.37.39.txt'
 LogPlayLevel:        (see C:\Users\oloug\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.19\UAT_Log.txt for full exception trace)
 LogPlayLevel: AutomationTool exiting with ExitCode=5 (5)
 LogPlayLevel: Completed Launch On Stage: Build Task, Time: 31.302487
 LogPlayLevel: BUILD FAILED
 PackagingResults: Error: Deployment failed! Unknown Error

Product Version: UE 4.19
Tags:
more ▼

asked Jun 28 '18 at 11:27 PM in Packaging & Deployment

avatar image

jamesoloughlin
26 1 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

James, PC isn't establishing a proper remote connection. SSH signing no problem? DeltaCopy ok? What exactly remote build options in project settings > iOS did you do?

more ▼

answered Oct 04 '18 at 09:16 PM

avatar image

Ijaz Naeem Ahmad
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question