x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting error disappears after changing build settings

Hi everyone,

I'm new to unreal, so this question may be kind of stupid:

We, a small team of students, are trying to build a walkthrough through our faculty building. Our modeling guy created the building with around 500 meshes without texture, just some colors. When I rebuild the lightning for the scene it says that most of the objects have overlapping UVs, as you can see in the screenshot (built with "Use error coloring")

alt text

The odd thing I'm wondering about is, that when I apply changes on the build settings in the mesh editor, for example, change the "Min Lightmap Resolution" from 64 to 128, apply, change it back to 64 and apply this happens:

alt text

The lightning error on this wall disappeared and is now working as it should. When I rebuild the light, the error shows up again.

Can anyone explain this to me?

Thanks for the answers and best regards,

wolverwin

Product Version: UE 4.19
Tags:
more ▼

asked Jul 04 '18 at 09:22 PM in Rendering

avatar image

wolverwin
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Open up the object mesh file and set the light map cordinate index to 1, that typically fixes it for me. If it is a custom model, if you use blender just go to edit mode and press U to unwrap it and then export it from there and it should work.

more ▼

answered Jul 05 '18 at 07:24 AM

avatar image

Forodin
43 4 4 7

avatar image wolverwin Jul 05 '18 at 12:49 PM

Thanks for the fast answer :)

Changing the lightmap coordinate index to 1 didn't fix the problem. It just looks different now: The first one is with index 0 and the second one with index 1.

with index 0 with index 1

I'm not that into modelling, but I think the problem with your second approach is for us, that the building consists of over 500 small parts. For this approach, we would have to unwrap every single one right?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question