x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

problem with ik animation

hi everyone,there is some problem when i put my character animation(setup with ik in maya) to the animation blueprint 1)this is the skeleton of my character alt text

2)and this is the animation after import to unreal engine,in this time it works normal(legs didn't move with body) alt text

3)however,after i put it in my animation blueprint,it works like this(body and legs move together) alt text

As a conclusion,i think it is because the body is the parent of those legs,so after put it in the animation blueprint,it body move with the legs,but i don't want the legs move with body (like step 2,and those legs are ik when animating in maya,so it doesn't move with its parent),anyone have solution?

Product Version: UE 4.19
Tags:
more ▼

asked Jul 05 '18 at 02:24 PM in Using UE4

avatar image

runner836223
22 2 4 7

avatar image MarketingMark Jul 05 '18 at 02:33 PM

Does UE4 even import IK data from maya? Maybe you will have to animate the legs using an IK setup with animation blueprints.

avatar image runner836223 Jul 06 '18 at 05:56 AM

yes,it is import from Maya and i setup IK when i am animating it in maya but i didn't setup IK in UE4

avatar image runner836223 Jul 06 '18 at 06:01 AM

I think the problem now is,i setup ik in maya so when the animation import,it works perfectly because the child bone (those legs) don't move with the parent bone(the body),like the gif in step 2. However after put it in the animation blueprints,it works weird and the child bone (those legs) move with the parent bone(the body),like the gif in step 3.

avatar image Atornity Jul 05 '18 at 03:14 PM

You should have a look at the root motion options. Force root lock in particular

avatar image runner836223 Jul 06 '18 at 05:54 AM

same after root lock,i think because it is not a root motion?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question