x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint creates new event tick on editor launch

Hello,

I recently stumbled upon a problem I have never seen before. At some point, some of my blueprints started creating new events on their own, replacing some previous events. I believe it was after merging a git branch (we are using UE4 source control plugin for it) but I'm not sure.

For instance, I used to do something in the Tick event in a blueprint, but everytime I close the editor, when I open it again, a new event is here in place of the event tick, called ReceiveTick_1, and giving me a warning until I compile the blueprint. And of course this new event is not fired, it doesn't seem to be a ticking event : alt text

It also happens for BeginPlay and one other function, everytime naming it with a "_1" suffix.

Has anyone ever seen this problem and do you know of a way to solve it ? It's really frustrating as I have to fix the blueprint everytime I launch the editor (committing and pushing the fixed version doesn't change the problem and I'm not even sure Git is the cause of this problem).

Thanks in advance!

Product Version: UE 4.15
Tags:
receivetick.jpg (15.3 kB)
more ▼

asked Jul 05 '18 at 03:08 PM in Bug Reports

avatar image

ZazarLaLiche
218 2 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm still not sure what caused it but switching the project version to 4.19 solved it. So it was probably a bug in an earlier version.

more ▼

answered Jul 06 '18 at 01:55 PM

avatar image

ZazarLaLiche
218 2 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question