x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Can't deactivate OnlineSubsystemNull

Hello! I have this awesome plugin called UWorks and it has it's own subsystem. I created a brand new project to test stuff and I followed the docs and entered this in DefaultEngine.ini:

 [/Script/Engine.Engine]

 !NetDriverDefinitions=ClearArray
 +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="/Script/OnlineSubsystemUWorks.IpNetDriverUWorks",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")

 [UWorks]
 AppID=732660
 ModDir=TheDarkDayPROJECT
 Product=732660
 
 [OnlineSubsystem]
 DefaultPlatformService=UWorks

Literally for everyone in their Discord it works, but not for me. Let me tell you what happens: Everything works fine, the plugins works, except for the Subsystem part. I am trying to create a session, but it gives me this error in the log:

 [2018.07.05-20.52.08:884][874]LogScriptCore: Warning: Script Msg: CreateSession - Invalid or uninitialized OnlineSubsystem
 [2018.07.05-20.52.08:884][874]LogScriptCore: Warning: Script Msg: CreateSession - Cannot map local player to unique net ID

If I scroll at the beginning of the log, I can see that it tries initializing the OnlineSubsystemNull, which I disabled from the plugins section, and of course, it fails with the following error (it's supposed to):

 LogModuleManager: Warning: No filename provided for module OnlineSubsystemNull
 LogModuleManager: Warning: ModuleManager: Unable to load module 'OnlineSubsystemNull' because the file 'C:/Program Files/Unreal Engine/UE_4.19/Engine/Binaries/Win64/' was not found.

Now, I don't understand why it tries loading the OSNull. I deactivated it everywhere, and it's not in mygame.build.cs as a dependency either. There are 2 possibilities here: It either tries loading the OSNull, or it cannot load UWorks and falls back to OSNull. So what could be it? I've been trying to fix this for like 2 weeks and can't figure it out!

Product Version: UE 4.19
Tags:
more ▼

asked Jul 06 '18 at 07:56 PM in C++ Programming

avatar image

JohnnyZer0
7 1 1 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question