x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Error: unknown error

Hey guys, I've been working through some errors with my project, and now I've managed to eliminate every error with my packaging except for this: alt text

I can't for the life of me understand what this means, I tried searching anything to do with GeneratedClass/ClassDefaultObject, but nothing is giving me any answers, and I don't have any blueprints with those names either.

I also get this string of errors when launching the game as well, even without packaging. It may not have anything to do with this, but I don't know what else to look for in the output log, which I have attached here. Any help would be appreciated, thanks in advance!

Edit: someone mentioned to install visual studio and generate the VS files associated with my project, I have packaged my project numerous times before, and have had no issues with packaging in the past.

Product Version: UE 4.18
Tags:
capture.png (186.8 kB)
uat-log.txt (744.9 kB)
more ▼

asked Jul 07 '18 at 08:09 PM in Packaging & Deployment

avatar image

TheCuddlyRoman
8 4 10 5

avatar image TheCuddlyRoman Jul 15 '18 at 12:00 AM

This issue is still persisting. I've attempted to update to 4.19, reset configs to default, and reload every single blueprint in my project, but to no avail.

alt text

¯\_(ツ)_/¯

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This question is solved over here, and the solution is very stupid. If you're from the future, and are finding this looking for answers, I wish you good luck. I solved my problem by migrating my project over to another empty project, then systematically deleting every asset in my project (while replacing with dummy assets so as to not create more errors) until I saw that the project packaged properly.

here's the link again, if you want it:

https://answers.unrealengine.com/questions/809382/unknown-cook-failure-caused-by-a-function-call.html

more ▼

answered Jul 17 '18 at 07:50 PM

avatar image

TheCuddlyRoman
8 4 10 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Install Visual Studio and the packages for ue4 in the Visual Installer selection then go to the options of ue4 in Epic games and check all the options and press ok

after all installed go to the folder of your project: Documents> Unreal projects> select the icon in blue my project with the right mouse button and click> generate visual studio files it will open and automatically check after this select in the right menu of the screen where it is at the top written My project and click recompile all

after finished save everything and close. In the packaging options, deselect the generate debug files option and try to package again.

more ▼

answered Jul 07 '18 at 08:22 PM

avatar image

TheSubZer0
114 8 13 17

avatar image TheCuddlyRoman Jul 08 '18 at 01:42 AM

I should've mentioned this, but I've Packaged my project successfully before with no issues. I have the recommended version of Visual Studio, and I already have the visual studio files associated with my project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question