x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Could not be compiled. Try rebuilding from source manually. Error MSB3075

As stated in the title it won't build the project. These are the 2 errors I get. I've been looking for answers for about 8 hours now and I can't figure it out. I'm not a programmer so any help would be greatly appreciated. Thank you

Error System.IO.FileNotFoundException: Could not find file 'C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject'. DreamChante C:\Users\Admin\Documents\Unreal Projects\DreamChante2\Intermediate\ProjectFiles\UnrealBuildTool 1

Error MSB3075 The command ""C:\Program Files\Epic Games\UE_4.19\Engine\Build\BatchFiles\Build.bat" DreamChanteEditor Win64 Development "C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject" -WaitMutex -FromMsBuild" exited with code 5. Please verify that you have sufficient rights to run this command. DreamChante C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets 44

Product Version: UE 4.19
Tags:
more ▼

asked Jul 08 '18 at 03:11 PM in C++ Programming

avatar image

GoatScreaming
3 2 3

avatar image DarkwindRichard STAFF Jul 09 '18 at 02:27 PM

"Could not find file 'C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject'"

Have you verified that your project file still exists? It hasn't been accidentally deleted somehow?

avatar image GoatScreaming Jul 10 '18 at 03:05 AM

Thank you for replying. I checked and supposedly the file exists but whatever reason it doesn't seem to be reading it. I have full control from what I can tell with no restrictions to my Admin account. I don't know how it would've gotten deleted I suppose it's still a possibility but it doesn't add up with what I just previously stated. All I did was exit the project without saving and I intentionally did that. I've done it before and haven't had any problems. The worst part of this I don't even know where to look or what to learn in order to start narrowing down what it could possibly be. Do you think it may have deleted a file from not saving somehow?

avatar image GoatScreaming Jul 10 '18 at 03:13 AM

I've done a little more digging and the file 'C:\Users\Admin\Documents\Unreal Projects\DreamChante2\DreamChante.uproject'. does exist but file DreamChante C:\Users\Admin\Documents\Unreal Projects\DreamChante2\Intermediate\ProjectFiles\UnrealBuildTool 1 doesn't or at least it can't find it. Am I toast?

avatar image DarkwindRichard STAFF Jul 10 '18 at 02:42 PM

Hmm... Have you tried deleting your Saved and Intermediate folders and regenerating your solution files? If not, could you do that and let me know if you get any new errors?

avatar image GoatScreaming Jul 10 '18 at 08:21 PM

I found the Saved and Intermediate folders but how do I regenerate solution files and where do I look for them?

avatar image GoatScreaming Jul 10 '18 at 08:56 PM

I googled what you were referring to and I deleted the specified files and regenerated the sln file went into MSVS and when I tried building it I first got the message alt text

It has asked me this for every different copy I made of the game sometimes it says win32 other times it's win64. I clicked yes and it started to build them this happened alt text

This is new to this particular copy of the project some of the other project copies did this too, however I was trying things that I had read off the internet otherwise what I had originally posted was consistent with all of them before experimenting.

avatar image DarkwindRichard STAFF Jul 10 '18 at 09:05 PM

Okay so for that error what you'll need to do is go into the solution explorer, right click on your project (not the UE4 project), and click "Set as StartUp Project." For some reason when you re-generate the project files the wrong default project will be set and you'll see the error you're seeing about being unable to find UE4.exe.

avatar image GoatScreaming Jul 10 '18 at 09:40 PM

I'm assuming you mean this folder alt text

I right clicked and selected the button and it took me to here alt text

What should I change inside of here since there are a fair amount of options assuming I'm in thee right place?

avatar image DarkwindRichard STAFF Jul 10 '18 at 09:48 PM

Nope, that's the solution and the solution properties. Here are illustrations of what to right click on, and then where to click afterwards.

alt text

alt text

avatar image GoatScreaming Jul 10 '18 at 10:47 PM

Did this. Now I've got this message and only this message from VS alt text

ue4solutiondc.png (10.0 kB)
avatar image DarkwindRichard STAFF Jul 10 '18 at 10:54 PM

What configuration (DebugGame Editor, DevelopmentGame Editor, etc.) and platform (Win64, etc.) are you building for? What happens if you go to "Build > Rebuild Solution" and then try to run after that? Do you still get that error message?

avatar image GoatScreaming Jul 10 '18 at 11:16 PM

I was using the local windows debugger the project was set to win32 I have x64 so I tried right clicking the project pressed build said it couldn't build because the project was built in 64. So I went into Solution>ConfigProperties and changed the project to win 64 I was unable to change the UE4 to 64 it only has win32. I built it then got this message

1>------ Rebuild All started: Project: DreamChante2, Configuration: HTML5_DebugGame_Editor x64 ------ 1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(48,5): warning MSB8005: The property 'NMakeReBuildCommandLine' doesn't exist. Skipping... 1>Done building project "DreamChante2.vcxproj". ========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========

I also tried the project rebuilding it same result. So then I went to the Solution pressed rebuild then I got this message

1>------ Build started: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------ 2>------ Skipped Build: Project: DreamChante2, Configuration: HTML5_DebugGame_Editor x64 ------ 2>Project not selected to build for this solution configuration ========== Build: 1 succeeded, 0 failed, 0 up-to-date, 1 skipped ==========

avatar image GoatScreaming Jul 10 '18 at 11:28 PM

Did I do what you meant or did I do something wrong?

avatar image GoatScreaming Jul 11 '18 at 12:02 AM

Config is HTML5_DebugGame_Editor x64 and build is unchecked below is BuiltWithUnrealBuildTool Win32 build is checked and there is no option to change from Win32

avatar image DarkwindRichard STAFF Jul 11 '18 at 02:26 PM

Try making a "Development Editor" build for Win64 (note that UBT is always Win32, that's fine) and see if you can run your editor from there. Your builds are succeeding (as noted by "Rebuild All: 1 succeeded, 0 failed, 0 skipped"), so it may have something to do with the HTML5 part of your configuration? I have no experience with HTML5 builds, though.

avatar image GoatScreaming Jul 11 '18 at 08:42 PM

This is the current config alt text

This is the new list of errors alt text

I'm not a programmer but I was following the UE4 bp twinstick shooter tutorial and there is C++ programming in the tutorial. I built it about 2 months ago and didn't have any problems using the engine on a daily basis. But based on the new errors I'm starting to wonder if that is the cause of this.

ue4-1.png (34.0 kB)
ue4-2.png (80.5 kB)
avatar image DarkwindRichard STAFF Jul 11 '18 at 09:29 PM

Those errors are suggesting that you've got functions declared in your header but not defined in your source files. Specifically the constructor, "BeginPlay," "Tick," and "SetupPlayerInputComponent" functions inside of your "AEnemyCharacter" class. Did you maybe delete them in the source file (EnemyCharacter.cpp) and then forget to delete them in the header (EnemyCharacter.h)?

avatar image GoatScreaming Jul 11 '18 at 09:32 PM

I don't recall deleting either of those things I remember wanting to but never getting around to it. Should I try deleting them inside VS and see what happens?

avatar image DarkwindRichard STAFF Jul 11 '18 at 09:37 PM

If you want to get rid of the entire class, you'll have to delete the files outside of Visual Studio. With the way UE4 sets up solutions, using Visual Studio's "remove" file from project simply removes it from the solution, but UBT will still attempt to compile it because it still exists within the project's source.

However, do note that any blueprints you may have created with that class as a base will most likely not work.

avatar image GoatScreaming Jul 11 '18 at 09:43 PM

There is only one other class but but it's the opposite because enemy character is based off of my character. So I'm assuming I will have to delete my character with the same method?

avatar image GoatScreaming Jul 11 '18 at 09:50 PM

Here are the files in Source alt text

Here is what is inside of the folder DreamChantealt text

ue4-3.png (15.9 kB)
ue4-4.png (25.8 kB)
avatar image DarkwindRichard STAFF Jul 12 '18 at 01:49 PM

Is this after deleting EnemyCharacter's source files? Have you tried rebuilding?

Also no, you would not need to delete the sources for your other character because the compiler errors were only for EnemyCharacter.

avatar image GoatScreaming Jul 12 '18 at 11:28 PM

I have not deleted the file and rebuilt it. Should I? Also, thank you

avatar image GoatScreaming Jul 12 '18 at 11:30 PM

I don't care honestly about the C++ characters because I'm not a programmer C++ is useless to me. I want to learn how to program but until that time there is really no reason to have this.

avatar image DarkwindRichard STAFF Jul 13 '18 at 06:36 PM

Yes, please try rebuilding. Based on your compiler errors, it seems like the enemy character was the only thing that was "wrong," so to speak, so having that completely removed (as long as you don't need it) should do the trick. As long as you don't have any blueprints that rely on your "MyCharacter2" class you should be safe to delete that as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question