x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't make APK without compiled .so

Hey all, I've recently set up a new machine to work from but I'm having issues deploying to Android. I've uninstalled and reinstalled both Unreal and Android codeworks several times now but had no success, I'm not using the GIT version of Unreal either which from searches over the past few days most people have had issues with in the past. Any help on this would be greatly appreciated.

LogPlayLevel: ====08/07/2018 19:19:45====PREPARING NATIVE CODE================================================================= LogPlayLevel: APK contains data. LogPlayLevel: Fixing minSdkVersion; requires minSdkVersion of 14 with Gradle based on active plugins LogPlayLevel: ==== Writing new GameActivity.java file to Y:\MassStorage\External\ConstructGames\Games\Parallax\Intermediate/Android/APK\src\com\epicgames\ue4\GameActivity.java ==== LogPlayLevel: ERROR: Can't make an APK without the compiled .so [Y:\MassStorage\External\ConstructGames\Games\Parallax\Binaries\Android\Parallax-armv7-es2.so] LogPlayLevel: (see C:\Users\User\AppData\Roaming\Unreal Engine\AutomationTool\Logs\Z+Applications+Epic+Games+Unreal+Engine+UE_4.20\Log.txt for full exception trace) LogPlayLevel: AutomationTool exiting with ExitCode=1 (Error_Unknown) LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 1.003638 LogPlayLevel: BUILD FAILED PackagingResults: Error: Launch failed! Unknown Error

Product Version: Not Selected
Tags:
more ▼

asked Jul 08 '18 at 06:25 PM in Packaging & Deployment

avatar image

Construct Games
28 3 3 8

avatar image adscastillo Aug 11 '18 at 04:04 PM

I have the same problem! have you solve ?

avatar image maxbrown Aug 23 '18 at 09:03 AM

Same problem here; "Can't make an APK without the compiled .so"


Only, in my case it worked with all projects and now I have this error with all projects in 4.20. Maybe its a coincidence but I upgraded yesterday from 4.20.1 to 4.20.2

Any suggestion what can be the cause and how to solve this?

edit:
- tried de-installing 4.20.2 and reinstalling 4.20.2
- tried re-installing AndroidWorks
- tested a 4.19 project - it still builds ok.

edit 2: I managed to get something working again;
- go to C:\Program Files\Epic Games\UE_4.20\Engine\Binaries\Android
- copy the .so and .target file
- go to your project \Unr\Binaries\Android
- paste these two files and rename them conform the error in the UE output log.
- change in project settings the packaging settings to Development. Un-tick ForDisiirbution

At least I can get a build going again from the menu. Launching to the GO from the top menu bar fails though with an error - this time it can't find the UE4Game-Android-Shipping-armv7-es2.apk file

avatar image maxbrown Sep 01 '18 at 06:40 AM

What 'fixed' it for me was completely de-installing UE and Androidworks altogether, restart Windows and re-installing them again. Until now, its been 1 week, haven't seen the error anymore.

avatar image biopharmacist Aug 31 '18 at 08:08 PM

Same problem here. Before, I was able to start a new project, copy over my content and it would work again. But this issue happens with even a new project now. How has it not been fixed? Which hidden setting am I missing to even test a brand new project on a phone? So frustrating.

avatar image biopharmacist Aug 31 '18 at 09:17 PM

Maybe I spoke a little too soon. I can package my game using the trick mentioned in my previous message. However, it is still impossible to launch/test on my phone from the editor. Is this feature being removed? Is there a manual way to compile the nonexistent .so file?

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

I've managed get it to work through a bit of an unconventional method. My project was a launcher project until 4.17, then it became a visual studio project 4.18, and then got converted to 4.20.3 back to the launcher version. That's when i got the 'performing final apk package operation error : "Can't make APK without compiled .so"

  1. Created an identical copy of the Unreal Project folder

  2. Used this copy to Generate Visual Studio Project Files (right click your yourproject.ueproject)(don't forget to delete the intermediate folder before)

  3. Then I started up Microsoft Visual Studio

  4. With 'Development' Solution Configuration and 'Android' Solution platform , I build the project.

  5. This in turn generated the Binary/Android files, in the project folder. The files it creates are yourproject.target , yourproject-armv7-es2.apk, yourproject-armv7-es2.so

  6. I then copied them over to the original project folder. Create the Binary/Android folder if there is not one.

  7. Building worked fine and the error was gone and it would deploy and launch on android.

This probably is not the best approach. But it is a workaround solution. If anyone knows a better way to get rid of the .so error without sorting to visual studio, please feel free to post.

The renaming of the .so file 'solution' , from @maxbrown seems to work for building the project, for me, but once it is deployed, my app it launches and close in rapid succession.

Another idea I thought of was migrating the level to an empty 4.20 project. Create an empty 4.20 project Open your project and migrate your assets to the new empty 4.20 project. This method however needs additional post-work to get it in into a functional gameplay state in which it used to be before.

more ▼

answered Oct 06 '18 at 01:10 PM

avatar image

JakobR
93 6 13 15

(comments are locked)
10|2000 characters needed characters left

has anyone solve the problem ?

more ▼

answered Aug 27 '18 at 04:48 PM

avatar image

adscastillo
1 1

(comments are locked)
10|2000 characters needed characters left

G'Day Guys and Gals....I can confirm after myself en-counting this issue above, and freaking out as I have Beta testers starting to test my game from tomorrow, the uninstall and reinstall of both Engine and Android SDK works perfectly!!! I just wanted to confirm in case any one else finds this post also. I can also confirm the Launch also works, it did for me anyway. So definitely uninstall and reinstall and you should be good!

Regards Shez

more ▼

answered Sep 11 '18 at 10:21 PM

avatar image

RS Digital Studio
10 1 1

avatar image PavelHuerta Sep 28 '18 at 10:21 PM

You use the UE 4.20.3 binary/launcher version or build from source? Thanks in advance for you reply!

(comments are locked)
10|2000 characters needed characters left

Hey PavelHuerta,

Na haven't tested it from source, which I also have. This was from the Binary/launcher. Had absolutely no dramas since!!!

Regards Shez

more ▼

answered Sep 29 '18 at 02:40 AM

avatar image

RS Digital Studio
10 1 1

(comments are locked)
10|2000 characters needed characters left

I was having the same issue.

Everything was packaging perfectly but when I was trying to reduce my package size, I turned some settings on and off. Right after that I got the " Can't make an APK without the compiled .so" error.

What worked for me: 1) I created a new empty project 2) Used Migration tool to migrate my game content folder to the newly created project 3) For input mappings, I exported the file by clicking export button in Project Settings-Inout->Export 4) Imported the input mappings in new project using import button in Project Settings-Inout->Import

After that packaging worked for me.

But again trying reducing the packaging size, I turned off some plugins like Oculus Plugin etc. which my game doesn't use, and the " Can't make an APK without the compiled .so" error came again.

So, I am assuming that this error is related to plugins used and project settings because I have migrated my project about 3-4 times after getting the error and after each migration, I can package my game but changing some plugins causes the error again.

more ▼

answered Oct 09 '18 at 06:44 AM

avatar image

Pankaj_Sati
8 1 2

avatar image Alex O ♦♦ STAFF Oct 09 '18 at 01:40 PM

Hello Pankaj,

Thanks for your workaround.

The plugin issue is know and currently being tracked at:

https://issues.unrealengine.com/issue/UE-63725

avatar image Pankaj_Sati Oct 09 '18 at 01:45 PM

Nice I hope they correct it soon because it is wasting a lot of time in migrating everything to new project

avatar image JakobR Oct 09 '18 at 01:52 PM

Indeed, seems quite a few people have the ' disable plugins' issue https://forums.unrealengine.com/development-discussion/android-development/1522236-disabling-any-plugins-causes-launch-to-fail

Hoping for a fix very soon.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question