x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Incorrect Android Resolution & Scale with/without HDR on older devices

Hello,

I've been noticing some weird behavior on Android devices with r.MobileContentScaleFactor and r.ScreenPercentage on some devices.

On a Samsung Galaxy S4, if HDR is enabled:

1) r.MobileContentScaleFactor does not work at all and the phone resolution is downscaled as if using 0.8 (Native res is 1920*1080 but with HDR it goes to 1024*576. There is no way to change this while HDR is enabled. 2) r.ScreenPercentage works

If HDR is NOT enabled:

1) r.MobileContentScaleFactor works perfectly 2) r.ScreenPercentage doesn't do anything

The above doesn't happen at all with a newer device (Samsung Galaxy S7). All these options work perfectly on both LDR and HDR.

Steps to reproduce:

1) Create a new project (any, maybe third person template) with HDR enabled 2) In DefaultDeviceProfiles set r.MobileContentScaleFactor to 1.0 and r.ScreenPercentage=70 for both Android_Mid (s4) and Android_High (s7) phones. In BeginPlay call a "GetViewportSize" node to get the resolution. 3) Launch the game. You'll see that the Samsung S4 the resolution is at 1024x576 and in the S7 is correctly 1280x720 (First problem) 4) Disable HDR, restart editor, relaunch the game. 5) You'll see that, in the S4, the resolution is correctly at 1280x720 but the ScreenPercentage is at 100, while the S7 has correct 1280x720 resolution with ScreenPercentage working correctly at 70 as well.

The above happens in both the 4.19 and the 4.20 preview. Note that my S4 is model GT-I9500 which has OpenGL ES2.0.

Can you please help me out? Thanks in advance.

Product Version: UE 4.19
Tags:
more ▼

asked Jul 08 '18 at 07:35 PM in Bug Reports

avatar image

FS Creations
26 2 3 5

avatar image Jeff A ♦♦ STAFF Jul 09 '18 at 01:10 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image FS Creations Jul 09 '18 at 03:07 PM

Thank you Jeff. I just created a bug report with the above form. Best regards.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question