x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Session is not created

I try to make Online Multiplay Game following Blueprint Multiplayer, posted on Unreal Engine page.

But I have something problem.

alt text

alt text

alt text

alt text

Above 4 pic is my Blueprint graph.

First is MainMenu Widget construct and Ready button event.

Second one is Create Session Event, which is on GameInstance

Third one is Join Game, and it's on GameInstance too.

4th is Login Event. It called from MainMenu's Ready button event.

Following these graphs, There's nothing to printed after print "Cannot find any session" if session created normally.

But it isn't.

alt text

I don'tt know where is problem.

Is there something wrong on Blueprints?

Product Version: UE 4.19
Tags:
hud.png (194.5 kB)
creategame.png (117.2 kB)
joingame.png (86.0 kB)
login.png (304.5 kB)
result.png (578.6 kB)
more ▼

asked Jul 10 '18 at 01:59 PM in Blueprint Scripting

avatar image

RedChiken
34 4 6 9

avatar image mightyenigma Jul 11 '18 at 04:54 PM

Do you mean there is no indication that it tried to Create Session after failing to Join Session?

What do your Output Logs say? Sometimes failures do not crash the game but they cause the Blueprint to stop executing on the wire they're currently doing, but everything else keeps going and that same Blueprint keeps executing other things and further attempts on the same wires, just not the one that generated the warning.

avatar image RedChiken Jul 12 '18 at 06:10 AM

This is logs alt text

log.png (24.4 kB)
avatar image Shadowriver Jul 12 '18 at 08:17 PM

Did you set up OnlineSubsystem properly? On Null only LAN listings work

Note that you don't need to create sessions to have multiplayer, users can still connect via IP addresses.

avatar image mightyenigma Jul 12 '18 at 09:33 PM

Yes it looks like you didn't configure your ini file to use the OnlineSubsystem the way you're trying to.

avatar image RedChiken Jul 14 '18 at 01:06 PM

Thanks to help. I check OnlineSubsystem and it doesn't set.

So I bought SubsystemConfigurator and set OnlineSubsystem.

Now it works.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question