x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Paper 2D sprites are blurry in GUI images

Hey, I'm working on a pixely 2D game and have this problem since I started. It's getting close to the point at which I want to show things to people, so I need to take care of it now :P

While my sprites look fine and seem to have the correct settings...

...they get blurry when used in a UMG widget image.

There have been a bunch of threads about this already, but for every one of them I've found, they either didn't get answered, or they forgot to apply Paper2D texture settings to their images. Sprites that are not parts of a widget and placed in the world instead look fine. I've included an auto-tiled image in the second attachment that shows the sprite in its original 16x16 size, but the blur is still there.

Any help would be greatly appreciated. Thank you!

Product Version: UE 4.16
Tags:
sprite.png (91.6 kB)
gui.png (300.1 kB)
more ▼

asked Jul 11 '18 at 01:22 PM in Using UE4

avatar image

Alfrink
3 5 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I recently got back at this problem and quickly found a solution. Setting "Filter" to "Nearest" fixes all said blur in GUI images. This can be found under "Texture" in the details panel of a texture, but is hidden by default (you have to either click the little arrow, or use the search bar to find it).The sprites look nice and crisp now.

I feel like this should be set automatically when applying Paper2D settings to a texture, but it isn't.

more ▼

answered Oct 12 '18 at 04:59 PM

avatar image

Alfrink
3 5 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

One thing to try would be disabling mip gen, since you dealing with a fixed distance. Could also set "Never Stream" under the advanced texture settings, though that probably won't do much.

If that doesn't work, the straight-forward way might just be to scale the images you're using for UI to actual size in an image editor.

more ▼

answered Jul 11 '18 at 04:43 PM

avatar image

Archduke_
159 2 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question