x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to stop UE4 from creating new Assemblies

How can i stop UE4 from generating new assemblies at compile time because VS will lose track and i can't attach to the process anymore (code version differs) and i have to reopen the Editor to make sure the code matches.

Doesn't help if i only use the Editor Compile button or compile in VS and I can't find an option in the Editor to make it stop pumping new DLL files with random build number in the file that VS doesn't see for some reason.

Edit: As seen in the picture, the 1st time I boot VS from the Editor I get only the 1st collection of files but if I modify the source code and recompile either in VS or the Editor, I get the 2nd collection of files added to the folder and it continues to do so as I compile more and more with more changes until a restart of the editor.

This is a problem i guess because when i re-attach VS for debugging, it tells me that the source is different and can't load the debug symbols and my breakpoints dont get hit.

alt text

Product Version: UE 4.19
Tags:
assemblies.jpg (38.9 kB)
more ▼

asked Jul 15 '18 at 10:04 AM in C++ Programming

avatar image

vlad3r08
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Now this is way over my competence but I remember reading something about "Compile Single File" which sound like it would possibly help.

Check the UnrealVS Extension documentation (if you haven't) here: https://docs.unrealengine.com/en-US/Programming/Development/VisualStudioSetup/UnrealVS

Apologies if I totally missed the point.

more ▼

answered Jul 15 '18 at 10:53 AM

avatar image

dZh0
1.3k 6 5 9

avatar image vlad3r08 Jul 15 '18 at 09:00 PM

Indeed I dont have the that extension installed and might give a test. Also dont worry any help is greatly appreciated and I've updated my question with more info please have a look.

avatar image dZh0 Jul 16 '18 at 12:46 PM

Apparently these files are actually the version of the game that runs in the editor as explained here: https://wiki.unrealengine.com/Understanding_Unreal%27s_Build_System and you can't apply your changes to the game without rebuilding them. (I guess) You can maybe use something from the UnrealVS extension for Quick Build options but I doubt that these files will disappear.

avatar image dZh0 Jul 20 '18 at 07:35 PM

How is it going? Any luck with loading the debug symbols?

avatar image vlad3r08 Jul 20 '18 at 08:07 PM

Hi, i.m still facing from time to time this issue and the only sure way is to close the editor and launch with ctrl+f5 from VS and once i.m in the editor i can safely attach then. Now that 4.20 is out maybe i.ll have a better time since this might be a gimmick of VS and UE4 working together.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question