x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Windows error sounds when working in Material Editor

This has been a problem since I recently started learning how to use Unreal Engine (version 4.19.2, Windows 10)

Whenever I am working in the material editor, every time I change something inside it, such as adding a node, changing a variable, adding a texture - really anything that causes it to update the material - there will be a few seconds and then I hear a Windows error sound. But there's no visible message, just the sound. Nothing in the message log, nothing in Event Viewer. I will also hear it several times when building the project, and I think it happens when importing materials as well. It does not occur when editing a Blueprint's event graph or anything similar.

I don't just want to turn my sound off or disable Windows error sounds altogether. I'm wondering if anyone else has had this issue before or knows what may be going on.

Product Version: UE 4.19
Tags:
more ▼

asked Jul 16 '18 at 12:17 AM in Using UE4

avatar image

Xombifier
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are you using Incredibuild? By default that plays a notification sound when a build finishes, and the XGE shader compile will go through Incredibuild.

If so, you can either turn off the build completion sounds in your agent settings, or disable XGE shader compilation.

more ▼

answered Jul 16 '18 at 10:11 AM

avatar image

Jamie Dale STAFF
7.5k 177 67 305

avatar image Xombifier Jul 18 '18 at 01:51 AM

That did it, thanks! Disabled it by running IncrediBuild Agent Settings --> Initiator --> General --> Build Completion Sound --> Don't play a sound. For anyone else who may stumble upon this issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question