Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Updated from 4.18.2 to 4.19.2 and localization no longer works.

If I test standlone with -Culture=fr for example, that would boot the game in French, now I see this:

LogInit: Overriding locale with culture command-line option (fr).

LogTextLocalizationManager: No localization for 'fr' exists, so 'en' will be used for the language.

And looking at the code in EndInitTextLocalization() the array AvailableCultures appears to be empty.

I've checked the LocalizationDashboard and everything looks OK. I re-compiled all the languages and double checked them and I can't see anything wrong.


Product Version: UE 4.19
more ▼

asked Jul 16 '18 at 05:32 PM in Packaging & Deployment

avatar image

21 1 8 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

When I upgraded the engine to 4.19.2, the Korean serialization of the project went wrong.Standalone game runs well with all the translations,But after packaging, the Korean translation is lost and all text is empty.I'm in a new space Project test and the Korean translation is still wrong,String scrambling. I fount that "Added an improved Korean font to the editor." as the engine released notes.but I do not know What's the cause of the wrong.

more ▼

answered Jul 20 '18 at 09:54 AM

avatar image

6 1 1

avatar image lelka1cog Aug 08 '18 at 03:14 PM

Same problem. Do you know, how to fix it?

avatar image Amstad Digital Aug 08 '18 at 09:36 PM

Guys any luck finding the solution to this? Struggling with the same issue here

avatar image ladyplaisir Aug 25 '18 at 11:21 AM

same problem - korean symbols just empty in packaged game. Any solution? I tried to replace the default font with another but it seem I had no luck in that.

Update: manage to merge 2 fonts - one that is my usual game font and the other one is that supports korean. It solved the problem with empty symbols

avatar image Jamie Dale STAFF Aug 26 '18 at 02:53 PM

We've been in the process of finally removing the semi-deprecated since 4.8 legacy fallback fonts. You'll likely find that whatever font you're using doesn't support Korean glyphs, and that the fallback fonts were hiding that.

Take a look at the font docs for more info about how to set-up a composite font: https://docs.unrealengine.com/en-US/Engine/UMG/UserGuide/Fonts/Overview

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

OK so I think I found it, apparently I need:

[Internationalization] +LocalizationPaths=%GAMEDIR%Content/Localization/MyLocalizationTargetName

In a game.ini. When I didn't have that it defaulted the localization target name to 'Game' - which is set in the engine/config/basegame.ini but that's not what mine was called.

Not sure how it worked before but adding that config entry fixed it after recompiling the text. Trouble is I've messed up all my translations in trying to work this out.

more ▼

answered Jul 16 '18 at 07:39 PM

avatar image

21 1 8 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question