x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Just updated to 4.20, getting error about missing "target file"

I just updated my project from 4.19.2 to 4.20. Its an IOS project that uses AR in case that's important, and I'm currently building it on a Window's system, so I use the Blueprint only method of coding to side load it onto IOS devices associated with my IOS developer certificate. I'm currently getting the following error code

ERROR: System.IO.FileNotFoundException: Could not find file 'D:\CyberPunky\Binaries\IOS\CyberPunky.target'.

I looked in the directory its naming, and that file isn't there. Is there some way to generate a target file using an installer based version of the engine?

Product Version: UE 4.20
Tags:
more ▼

asked Jul 18 '18 at 08:18 PM in Using UE4

avatar image

aaron_saluk
61 7 12 20

avatar image ms_xcyde Aug 30 '18 at 01:49 PM

I have the same Issue. Were you able to resolve it? My issue seems to be related to some plugins from what I can tell.

avatar image aaron_saluk Aug 30 '18 at 02:33 PM

I ended up buying a Mac, that was the only solution that I could find for my specific problem.

avatar image Justice4000 Oct 18 '18 at 05:08 AM

Tested on both Windows and Mac with UE 4.20.3 blank blueprint only project - same problem. UATHelper: Packaging (iOS): ERROR: System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Projects\UE4\IOSTest\Binaries\IOS\IOSTest-IOS-Shipping.target'. is missing I see no "Binaries" directory inside of my project dir structure. I suppose it should be created by the engine?

avatar image danielspoa Aug 30 '18 at 01:58 PM

Just came because I'm facing a file not found exception since I updated to 4.20.1, but with another plugin. Not sure if related, want to leave this here:

ERROR: System.IO.FileNotFoundException: [..]Epic Games\UE_4.20\Engine\Plugins\Lumin\MagicLeap\Intermediate\Build\Win64\UE4\Development\MagicLeapHelperOpenGL\MagicLeapHelperOpenGL.precompiled'.

avatar image OptimisticMonkey Sep 20 '18 at 02:12 AM

I am getting this on 4.20 as well...

Can you deploy BP-only to device from windows anymore on 4.20? (this is for a non-AR project too)

avatar image RumbleMonk Sep 24 '18 at 12:57 PM

Running 4.20.3 here, get the same exact problem with the .target file on my BP-only project while trying to deploy from my project onto iPhone as 'development'.

I've renamed my project to not contain spaces, removed 'intermediate' and 'saved' folders but as expected no luck.

I've deployed successfully many times on the same project from earlier versions of Unreal. My project was an upgraded project from way back, perhaps 4.10.

If anyone has a solution it'd be great to hear.

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

I was having the same issue trying to build onto iPhone. Solution for me was to have the online subsystem plugins enabled, both for iOS AND Google for some reason.

more ▼

answered Oct 23 '18 at 09:33 AM

avatar image

Grandison
6 1 3

(comments are locked)
10|2000 characters needed characters left

i have the same problem, i upgraded my project from 4.12 to 4.20.3 i build my project on windows, only blueprint

UATHelper: Packaging (iOS): ERROR: System.IO.FileNotFoundException: Could not find a part of the path 'D:\UnrealProjects\MinskProject_4.20\Binaries\IOS\MinskProject.target'.

solution with enable online subsytem plugins dont work for me, unreal requires a server name

more ▼

answered Oct 24 '18 at 12:53 PM

avatar image

Yabol
1 1 2 2

(comments are locked)
10|2000 characters needed characters left

I have exactly the same problem trying to launch the AR handheld blueprint template remote from my win10 via a macbook on to my iphone. Launch starts compiling all shaders then I get the error about the missing Projectname.traget file in Binaries\IOS.

enabling online subsystem plugins doesn´t help me either. Any solution for this?

more ▼

answered Oct 24 '18 at 03:47 PM

avatar image

DIO_666
26 1 4

avatar image ConvictGames Oct 30 '18 at 12:43 PM

I have the issue as well! It says missing .target file during launch through editor using a BP only project on Windows.

Using a default mobile project using 4.20.3, the process works.

However at this point I'm porting my 4.20.3 project to iOS, so a fresh start is not an option.

Any ideas anyone?

(comments are locked)
10|2000 characters needed characters left

I had the same problem and I resolved it somehow, but I'm not exactly sure how, it's been a while. I think it just had to do with the .uproject not having "Enabled": true set correctly for the plugins or the .uplugin not having "Installed": true. Maybe someone could try this and see if it helps.

more ▼

answered Oct 31 '18 at 07:31 AM

avatar image

ms_xcyde
1 1 2

avatar image ConvictGames Oct 31 '18 at 07:56 AM

Hey thanks for the reply! Could you elaborate a bit more? It sounds like you think it was a plugin issue?

What do you mean by .uproject, as in the file you use to start the project?

I can't find .uplugin too.Where is that stored and set to "Installed"?

avatar image ms_xcyde Oct 31 '18 at 08:23 AM

In the root of your project you should have this .uproject file which is essentially a json file. It will be opened using ue4 by default but you can just right click -> open with -> any text editor. The .uplugin files are located under /Plugins//pluginName.uplugin. Same deal here, just open it with a text editor.

Also make sure to have a backup of these files.

avatar image Yabol Oct 31 '18 at 08:16 AM

thx, i think it work early in .uproject i have:

 "Plugins": [
     {
         "Name": "OculusLibrary",
         "Enabled": false
     },
     {
         "Name": "SteamVR",
         "Enabled": false
     },
     {
         "Name": "VisualStudioCodeSourceCodeAccess",
         "Enabled": false
     }
 ],

when i delate this, project build with no errors

(comments are locked)
10|2000 characters needed characters left

Works for me too now ! Thanks so much ms_xcyde :)

more ▼

answered Oct 31 '18 at 08:35 AM

avatar image

ConvictGames
1 2 4

avatar image Yvasquez Mar 13 '19 at 07:55 PM

Hi all!. I have this same problem when trying to compile from a mac. Looking in .project to see that it has enabled the subsystem. but I still get the same error. I am already somewhat desperate with this, because I must upload the version of my game soon to the IOS. Thanks in advance for the help

avatar image ConvictGames Mar 14 '19 at 08:49 AM

Hey try to remove all the plugins from the .uproject text file for now and make sure in the project setting it has been setup correctly too. Hopefully it allows the export.

Good luck and in my case it was the fact the project setting value was not being change correctly from in editor.

avatar image Yvasquez Mar 14 '19 at 10:43 PM

disable the subsystem plugins and re-enable them. Followed by that, generate the project build. Once my .IPA was generated in the binaries folder, it was already on. target, which I can launch without problems. Thank you

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question