x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem with New Projects 4.20.0 - Cannot Open Source Files

So I just updated from 4.19.2 or something to the latest UE4 version, and when I now create a new C++ Project with "Blank Code" and add a New Class (Like an Actor) to it, Visual Studio pops out a big bunch of errors, for example:

E1696 The File "source" can not be opened: "ActorComponent.generated.h". TUTORIAL c:\Program Files\Epic Games\UE_4.20\Engine\Source\Runtime\Engine\Classes\Components\ActorComponent.h 17

It is a clean new project, so probably some SDK is outdated, idk. Help pls!

Visual Studio Version: VS2017 Professional

Product Version: UE 4.20
Tags:
more ▼

asked Jul 18 '18 at 09:35 PM in C++ Programming

avatar image

Dyshaxo
41 2 3 3

avatar image Dyshaxo Jul 18 '18 at 10:13 PM

alt text

unbenannt.png (206.4 kB)
avatar image Ryujin Ishima Jul 19 '18 at 04:49 AM

Bump. Facing the same issue. Also had it in the UE 4.20 preview versions

avatar image TacoShank Jul 19 '18 at 05:31 AM

I also have the same issue. I hope this has some kind of solution because it makes intellisense completely unusable.

avatar image Dyshaxo Jul 19 '18 at 11:25 AM

I actually didn't have that on 4.19.0 - so I was really confused when this showed up.

avatar image Ryujin Ishima Jul 19 '18 at 12:37 PM

Yea it's the same for me. Btw, it's alright for you to use 4.19 and switch to 4.20 whenever this intellisense error is fixed Just right click .uproject file and switch engine version when you need to.

avatar image SliverLIVE Jul 19 '18 at 05:24 PM

Same for me!

avatar image Frigerius Jul 19 '18 at 05:29 PM

I had the same question, damnd, didn't find your question, when I was searching for this issue: https://answers.unrealengine.com/questions/809801/ue420-is-missing-the-intellisense-includepath-for.html Short: IntelliSense includes pathes are missing

avatar image Taberu Aug 26 '18 at 01:11 PM

Same issue here. Any new info?

avatar image Ryujin Ishima Aug 26 '18 at 01:13 PM

@Taberu It's been fixed in 4.20.2 update

avatar image Taberu Aug 26 '18 at 03:07 PM

@RyujinIshima Actually, I thought I resolved the issue but when I added a new class to my project, the IntelliSense got crazy again.

avatar image Frigerius Aug 26 '18 at 03:09 PM

Did you rightclick your *.uproject and regenerated the project files?

avatar image Taberu Aug 26 '18 at 04:51 PM

I just tried it, sadly no real effect.

avatar image Frigerius Aug 26 '18 at 05:17 PM

You can try using my python 3.6 script, which should add most of the missing includes paths: https://answers.unrealengine.com/questions/809801/ue420-is-missing-the-intellisense-includepath-for.html And could you describe you problem in more detail?

avatar image Taberu Aug 26 '18 at 05:54 PM

I just switched to 4.19 where I had no issues and now after adding a c++ class, IntelliSense is outputting the same bulls**t as in 4.20, it looks exactly the same as in the Dyshaxo's screen shot above.

Here is also the output when I press rebuild in VS, clean project with 1 additional c++ class:

 1>------ Rebuild All started: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
 2>------ Rebuild All started: Project: ProjectName, Configuration: Development_Editor x64 ------
 2>Cleaning ProjectNameEditor Binaries...
 2>UnrealBuildTool : error : Unable to clean target while hot-reloading. Close the editor and try again.
 2>Creating makefile for hot reloading ProjectNameEditor (modules to compile have changed)
 2>Compiling game modules for hot reload
 2>Target is up to date
 2>Deploying ProjectNameEditor Win64 Development...
 2>Total build time: 24,86 seconds (NoActionsToExecute executor: 0,00 seconds)
 2>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(49,5): error MSB3073: The command ""C:\Program Files (x86)\Epic Games\UE_4.19\Engine\Build\BatchFiles\Rebuild.bat" ProjectNameEditor Win64 Development "<my_path>\ProjectName\ProjectName.uproject" -WaitMutex -FromMsBuild" exited with code -1.
 2>Done building project "ProjectName.vcxproj" -- FAILED.
 ========== Rebuild All: 1 succeeded, 1 failed, 0 skipped ==========

Do you have any idea why is it like that? Thank you for your time!

avatar image Frigerius Aug 26 '18 at 05:57 PM

Well the error says Unable to clean target while hot-reloading. Close the editor and try again. For the rest, no Idea, since the information you give me are not enough^^

avatar image Taberu Aug 26 '18 at 06:26 PM

Indeed, closing editor allowed VS to execute the clean up properly, but I just considered it irrelevant. I'm not sure if there are less errors after rebuilding the project. I tried to regenerate project files as well, no difference. What left is this small syntax error about missing ')' in my code, here is a screen shot: alt text

When I click the error, it takes me to Atomic.h (which is not my project's file) and oh my, IntelliSense displays 5431 errors there. Here is a screen shot: alt text

I will try to turn off IntelliSense and do my small project for now. I don't have much time to fix VS problems when these are not blocking my progress.

Thank you for your help! Maybe in a month I will have to try to fix it, maybe an update will fix it for me, who knows. If you have any more thoughts, let me know!

expected.png (5.3 kB)
atomic.png (106.8 kB)
avatar image chrgra Sep 16 '18 at 10:11 AM

I found the following solution here: https://answers.unrealengine.com/questions/822711/atomich-error-in-all-new-projects.html

It says that the "ApplicationCore" module has to be added to PublicDependencyModuleNames. For me this solved the Atomic.h error.

avatar image KWS Sep 18 '18 at 02:52 PM

You're saying that changing:

 PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore" });

to:

 PublicDependencyModuleNames.AddRange(new string[] { "ApplicationCore", "Core", "CoreUObject", "Engine", "InputCore" });

fixed the expected a ')' error? :\

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question