x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Geometry Cache Animation not working in UE20

Hi, I am currently working on a project which has some geometry cache and has been working great until I updated my Unreal from version 4.19.2 to 4.20.0. Now I get this error: "Geometry Cache asset has been emptied as it does not support backwards compatibility". I tried re-importing the asset, and the character comes in, but the animation seems to not come in because the character remains static even when rendering a movie. I also made sure to have the "running" attribute on, but it still does not play the animation.

Is there something in the settings that I need to turn on in order to get the animation working? I have attached my current import settings.

[1]: /storage/temp/247997-geocachesettings.png

Thank you in advance!!

Product Version: UE 4.20
Tags:
more ▼

asked Jul 21 '18 at 12:39 AM in Using UE4

avatar image

SaraiZMayes
18 1 2 7

avatar image Gondo the Boo Aug 23 '18 at 12:37 AM

I have a similar problem, My geometryCacheActor is now not working after 4.20 upgrade. The actor itself exists, but when dragged into a level is invisible.

avatar image SaraiZMayes Sep 22 '18 at 01:32 AM

Hi,

I am sorry if this is too late, but I did end up finding a way to get all the animation in using alembics. I am not sure why but these are the settings that worked for my project. I found that using the sampling type: "Per Frame" ended up dropping some of my frames and the animation looked choppy.

Hope this works for you too

geocache-001.png (57.0 kB)
geocache-002.png (31.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question