x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4.20 and Visual Studio 2017 Errors

Hello,

I have recently downloaded UE4.20 and also Visual Studio 2017. To be able to use Visual Studio 2017 I chose it as the source code editor. The code compiled without any problems, however inside the IDE, I am getting errors saying that some of the header files are inaccessable, even though they worked fine in 4.19 and Visual Studio 2015.

alt text

This doesn't cause any issues with the compiler. Has anyone else had a problem like that? And how was it solved?

Product Version: UE 4.20
Tags:
dsgaeg.png (44.2 kB)
more ▼

asked Jul 21 '18 at 09:12 PM in C++ Programming

avatar image

UmeerFI
14 4 4 8

avatar image 23456agder Mar 11 '19 at 11:13 PM

One way that I found is to delete the folder where the public and the private one are, because in the editor ue4 it does not find them as such, then once the private folder is deleted and in case it saves the files created in that private folder, restart and It was automatically corrected, it's something foreign to ue4, I hope it helps this ..

avatar image 23456agder Mar 11 '19 at 11:14 PM

Una forma que encontré es borrar la carpeta donde esta el public y el privado, pues en el editor ue4 no los encuentra como tal, entonces una vez borrado la carpeta privado y por si acaso salve los archivos creados en esa carpeta de privado, reinicie y se corrigió automáticamente, es algo extranio de ue4, espero que ayude esto....

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first
more ▼

answered Jul 22 '18 at 03:31 AM

avatar image

Sveitar
1.1k 8 24 29

avatar image Para96 Jul 22 '18 at 08:55 AM

I followed your instructions but it's still giving me errors on the include of generated files and the generated body

avatar image Sveitar Jul 23 '18 at 06:54 PM

I fixed the path, try again now. Also vote here so Epic fixes this quickier https://issues.unrealengine.com/issue/UE-62042

avatar image Para96 Jul 23 '18 at 07:02 PM

Can confirm, this fixes the issue everything works now including generate_body One remark though the path contains 2 "/" before YourModuleName (should only be 1)

Thank you very much

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It's not telling you that the header is inaccessible, but that the individual member in question is. Many previously-public members in 4.19 have been made private in 4.20 and exposed through accessors. I'm not in a position to check this particular case here, but when updating to 4.20, I did have to make changes like the following to my own classes:

 StaticMeshComp->bGenerateOverlapEvents = false;

to

 StaticMeshComp->SetGenerateOverlapEvents(false);

It's likely that you're in a similar situation and need to replace direct references to these member variables with calls to accessor functions.

more ▼

answered Jul 21 '18 at 10:56 PM

avatar image

KevODoom
201 5 8 19

avatar image UmeerFI Jul 21 '18 at 11:26 PM

Thank you very much for your reply, but something else is causing these errors as well, since it also doesn't like Super::BeginPlay();, Super::Tick(DeltaTime);, SetupPlayerInputComponent and Generated_Body() alt text

alt text

afwa.png (47.7 kB)
aseg.png (63.4 kB)
avatar image Para96 Jul 22 '18 at 01:11 AM

I'm also experiencing this problem

I tried creating a new project (just in case something changed in this regard) but in the new project i'm also getting an error on all of the includes of *.generated.h files aswell as the GENERATE_BODY macro

avatar image TheAwesomeGem Jul 22 '18 at 02:02 AM

I am also experiencing the same issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question