x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Package project for Windows creates no exe

I am trying to package a project, but I don't get an exe.

I am using File->Windws->Windows 64. It generates the WindowsNoEditor folder just fine, but it only contains [ProjectName].uproject but no [ProjectName].exe, despite showing Package complete!.

The only exe I can find is in the Engine folder named "UE4PrereqSetup_x64.exe", which doesn't seem to be the right one.

Product Version: UE 4.20
Tags:
more ▼

asked Jul 22 '18 at 12:53 AM in Packaging & Deployment

avatar image

Unavi
21 1 5 5

avatar image Shadowriver Jul 22 '18 at 02:01 AM

Thats wierd there should not be uproject in there you sure you looking in right directory? check the log to see everything gone well in your packaing

avatar image Unavi Jul 22 '18 at 02:58 PM

It says BUILD SUCCESSFUL. Looks fine in the log, no warning or errors and states a few times success. PasteBin folder with .uproject

capture.png (7.6 kB)
(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

I got my project to create an exe.

I tried it with the project launcher and suddenly got errors which didn't appear previously. Different versions of Bad name index -1/96. I am not 100% sure if that is the only thing I did, because I tried many different things. Bad name index turned out to be a problem with the capitalization of files (T_file renamed to T_File). I changed the file name to T_File2 and then to T_File, just change something that is not case related, and it should fix it. As to, how you find out which files may cause the Bad name index, I can't really help you because at least I didn't get any file names. Luckily my test project isn't really big.

more ▼

answered Jul 24 '18 at 02:49 PM

avatar image

Unavi
21 1 5 5

avatar image Mirrol Jul 24 '18 at 07:06 PM

Yes this worked for me! Turns out I had to update visual studio. alt text

error.png (135.6 kB)
(comments are locked)
10|2000 characters needed characters left

I had the same problem, in my case helped setting Settings -> Packaging -> Project -> Build to Always.

more ▼

answered Oct 23 '18 at 10:53 PM

avatar image

Женёq
21 5

avatar image Dr. Whoop DSc Nov 15 '18 at 04:00 PM

This fixed it for me, though my project launcher error was slightly different than OP (Index was out of range. Must be non-negative and less than the size of the collection. )

Thanks!

avatar image JRV1 Mar 06 '19 at 03:07 PM

This requires Visual Studio, just fyi.

(comments are locked)
10|2000 characters needed characters left

I'm having the same issue.

more ▼

answered Jul 22 '18 at 08:47 PM

avatar image

Mirrol
21 3 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question