x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Updated to 4.20, now I can't build

I switched over my project file to 4.20, and then selected Generate VS project files. Now, when I build, it fails on the first file in my solution. It says: cannot open source file "ActionMapInterface.generated.h"

But I did generate the project files. I've already tried deleting the Intermediate folder and re-generating the project files. Got the same error.

I also made sure to build in 4.19, and correct any deprecated code that showed up before switching over to 4.20. I really can't tell what is going wrong, and I wish Epic gave us some better error messages or something. Right now it just says the build "exited with code -1" and ...

UnrealHeaderTool failed for target 'VR_Test_2Editor' (platform: Win64, module info: C:\SynthStudio\Intermediate\Build\Win64\VR_Test_2Editor\Development\VR_Test_2Editor.uhtmanifest, exit code: OtherCompilationError (5)).

Any ideas?

Product Version: UE 4.20
Tags:
more ▼

asked Jul 22 '18 at 08:05 AM in C++ Programming

avatar image

Chris Gallegos
1 1 2 2

avatar image Dark Energy Jul 22 '18 at 08:50 AM

Do you have visual studio 2015 or 17?

avatar image Chris Gallegos Jul 22 '18 at 08:20 PM

I have VS 2017.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I had this problem too. The Error List didn't say much but looking at the Output tab showed an error not listed on the Error List.

 LogCompile: Error: Pickup: Override of UFUNCTION in parent class (Pickup) cannot have a UFUNCTION() declaration above it; it will use the same parameters as the original declaration.

This particular error is a new change in 4.20 I believe.

Double check your Output tab in VS carefully if it shows any errors not shown in the Error List.

more ▼

answered Jul 24 '18 at 12:55 AM

avatar image

DanimalsOnParade
68 4 11 14

avatar image kbrizov Sep 22 '18 at 12:24 PM

You saved my project. What is curious is that my output log didn't show this error which is clearly an Unreal Header Tool issue. Perhaps my settings are not correct in order to display it. Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question