x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

IOS game crashes after launch and default splash screen

When I launch my game's level from the editor to my IOS device, everything compiles and build fine as far as I can see. But after the splash screen shows, my game crashes. I have been looking into this for some days now, but I cannot figure out why this happens.

I attached the output log from the editor and the crash log from my device.

I really hope that someone can see what's causing this. Thanks! link text link text

Product Version: UE 4.19
Tags:
more ▼

asked Jul 22 '18 at 08:15 AM in Packaging & Deployment

avatar image

iProspartan117
22 5 5 11

avatar image dZh0 Jul 22 '18 at 09:23 AM

Does it run on Windows?

avatar image iProspartan117 Jul 22 '18 at 10:09 AM

Yes, it runs, Not as it's supposed to run.. but it runs, no crashes or whatsoever.

avatar image mightyenigma Jul 23 '18 at 05:31 AM

I had this same problem on an older Android device because it had not enough RAM on the device to load the engine let alone the game content. Maybe you have exceeded the iPhone's RAM

avatar image iProspartan117 Jul 23 '18 at 11:54 AM

That could maybe be the problem. But somehow, it's fixed now. I was trying to symbolicate the .crash file from my IOS device, but since I had no .dSYM file, I was not able to.. Then I checked two boxes in de IOS project settings which had to do with generating that .dSYM file, and suddenly, it launches.

avatar image mightyenigma Aug 08 '18 at 11:28 PM

Weird. No idea why?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Have you tried packaging out the .ipa file and loading onto the device using iTunes? I have found that the launch system can sometimes cause freezes on the splash screen which seem to only be fixable by deleting the "Build" folder in the project directory and deleting the app on the device before re-launching.

more ▼

answered Aug 09 '18 at 12:00 AM

avatar image

ianoreo
127 11 15 19

avatar image iProspartan117 Aug 09 '18 at 06:48 AM

I have not tried this, but as posted in another question: https://answers.unrealengine.com/questions/816218/getting-data-from-struct-crahses-ios-game.html

I have found out that rebuilding in Xcode first can also solve the problem of getting crashes after the splash screen.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question