x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Join session in blueprint IOS app crashes after upgrading to 4.20

After upgrading my project to 4.20 and migrating it over to a Mac, I’ve lost the ability to test multiplayer, since the “join session” node always causes a crash now. I have a blueprint based project that I’ve converted to a code project since switching over to a Mac.

Product Version: UE 4.20
Tags:
more ▼

asked Jul 22 '18 at 06:53 PM in Bug Reports

avatar image

aaron_saluk
56 7 12 20

avatar image aaron_saluk Jul 22 '18 at 09:58 PM

I created a clean project from the third person C++ example project, and added the same create and join session code in a blueprint. I had the same exact results, the client app crashes whenever it tries to join an existing session.

avatar image aaron_saluk Jul 24 '18 at 02:17 PM

I’ve rebuilt the clean project to run in the editor, and multiplayer works well there, so I did the same with my AR project, and the multiplayer works in the editor there as well. The only problem with the multiplayer comes when I load anything onto an IOS device.

avatar image aaron_saluk Aug 01 '18 at 02:56 PM

I bought a new router, and that helped, because now the client can join sessions, but the map doesn’t load on the client, only on the server. I’ve tried to use an execute console command node with “ServerTravel Map_Name?listen” but that didn’t work either.

avatar image Jeff A ♦♦ STAFF Aug 03 '18 at 02:44 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image aaron_saluk Aug 04 '18 at 01:52 PM

I put in a bug report for this yesterday, but unfortunately I filled out the “title” portion with my job title instead of the bug’s title. So if anyone is looking for this one it should say something like “game technical artist” right now. Hopefully it can still get sorted out.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question