x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Manifest Bug, Prevents launching on device

I have found an unusual Bug when launching to Android found in both 4.19 and 4.20 and I was wondering if anyone has seen it before.

The bug is caused because the Manifest_UFSFiles_android.txt* file is written incorrectly.

i.e. this line gets wrote

/GearVRControllerMaterial.uasset 2018-07-20T20:43:10.000Z

instead of

Engine/Plugins/Runtime/Oculus/OculusVR/Content/Meshes/GearVRControllerMaterial.uasset 2018-07-20T20:43:10.000Z

I believe this is caused by the localisation toolkit due to localisation being mixed up after this but I have yet to replicate in new project

this is error when trying to launch

 Running: C:\NVPACK\android-sdk-windows\platform-tools\adb.exe -s M2HDU18310002543  pull /sdcard/UE4Game/AdvancedVehicleKit/Manifest_NonUFSFiles_Android.txt "D:\Racing-Game\Saved\StagedBuilds\Android_ASTC\Manifest_NonUFSFiles_Android.txt_M2HDU18310002543"
 LogPlayLevel: Took 0.050954s to run adb.exe, ExitCode=0
 LogPlayLevel:

 ERROR: System.ArgumentException: Attempt to construct staged filesystem reference from absolute path (/GearVRControllerMaterial.uasset). Staged paths are always relative to the staging root.
 LogPlayLevel:           at StagedFileSystemReference..ctor(String InName)

This only occurred on Android 8+ devices.

Log file here https://pastebin.com/UKih6N5d

Link to manifest file here https://drive.google.com/open?id=1_V4MtMJNBDzCwJZ9AwyRcgp49Dx31c0t

If anyone has seen this before I would love to know a solution

Thank you :D

Product Version: UE 4.20
Tags:
more ▼

asked Jul 23 '18 at 04:13 PM in Packaging & Deployment

avatar image

Taikatou
98 2 5 11

avatar image Dtb49 Jul 24 '18 at 10:10 PM

The same thing is happening to me. Except it is only happening to one of my phones the other one it launches on fine. I tried deleting the app off of my phone, restarting it, restarting Unreal, deleting the Staged Build folder and Cooked folder but, nothing. I can't figure out why it is happening. Would really like to know how to fix this.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I know how to fix this now. Go into phone storage and delete UE4Game folder it's a broken manifest file from a failed build that is not cleaned up

more ▼

answered Jul 24 '18 at 10:15 PM

avatar image

Taikatou
98 2 5 11

avatar image Dtb49 Jul 25 '18 at 01:01 PM

That worked! Thanks so much.

avatar image notrealvitor Nov 15 '18 at 06:01 AM

yes! It worked for me too! I tried to launch while the game was still open in the phone, then it failed and kept failing even after deleting the game and cleaning the project, etc.. didnt think about delete the folder, thanks!

avatar image MTurk Nov 24 '18 at 08:49 PM

it worked thanks a lot!

(comments are locked)
10|2000 characters needed characters left

I figured it out

Delete UE4Game folder in the phones storage the manifest file from a broken build is corrupting the launch process

more ▼

answered Jul 24 '18 at 10:17 PM

avatar image

Taikatou
98 2 5 11

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question