x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unable to select a specific skeletal component in an array

Hey folks, I got stuck at this problem for more than 2 days. I'm desperate and I don't know what to do. Please help me. I want to make a function to switch the windows in a house when the window is hit by a line trace. The player can also use it to select a window to resize it.

What I did so far was making all the original windows into an array and when the line trace hits it, the blueprint will get the selected window's location and switch it to a new one. Where I got stuck at is that the window doesn't let me resize it for some reason. You can see my blueprints below: alt text

I tried to use a "contains" and "find" node for the array. But it says that component type is not compatible. alt text

Here's a screenshot of my line trace blueprints: alt text

I'm new to blueprints and I've been spending a lot of time searching for the a solution online and tried everything I could do. But the blueprints are still not working. I will very much appreciate if anyone can point me to the right direction on what I did wrong. Please let me know if I can provide any further information if it helps to solve the problem or make the question more clear. Thanks in advance!

Product Version: UE 4.19
Tags:
more ▼

asked Jul 24 '18 at 12:26 AM in Blueprint Scripting

avatar image

fortsts
29 3 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question