x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Engine VR | There seems to be a conflict when I grab and when I move forward using the motion controlle

So I made It where you can walk around using the motion controller, and It works perfectly fine! Well that Is until you hold down either one of the grab buttons, when you hold either grab button and try to walk It will make you go in one direction. Holding the right grab button will make you move to the right, and holding the left will make you go backwards. Any help Is appreciated ^^

alt text

Product Version: UE 4.19
Tags:
more ▼

asked Jul 24 '18 at 06:03 AM in Using UE4

avatar image

ItsLightsaber09
15 2 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I fixed my problem, I had to edit the motion controllers collision, If you go to the blueprints for the motion controllers theres an option for left hand colliding with enviroment when gripping. I deleted that as well as made It so the objects im grabbing ignore pawn collision and everything works perfectly! But thank you so so much for the help!

more ▼

answered Jul 24 '18 at 05:38 PM

avatar image

ItsLightsaber09
15 2 3 5

avatar image DarkFearHunter Jul 24 '18 at 05:39 PM

glad to see you figured it out

avatar image SuperfuntimesV May 04 '19 at 02:36 PM

Hi everyone,

I had this same issue with very similar blueprints. ItsLightsaber09's solution above was correct, though mine was a bit different: I set my "Set Collision Enabled" for my grab to "Physics Only". For each object that can be picked up, as the OP said, set the collisions to custom and disable pawn collisions.

Working great for me now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm not sure if this helps, but i was having an issue where whenever I gripped with my hands, the grip collision would collide with my character pawn which would stop me from going in some directions or even fly if i put my hand under my self. Try making the collision on your hand grip sphere to Ignore collision with your charater. so unless you changed the collision presets of your character you would make the motion controller grabsphere ignore the collision of the pawn.

more ▼

answered Jul 24 '18 at 06:19 AM

avatar image

DarkFearHunter
13 2 6

avatar image ItsLightsaber09 Jul 24 '18 at 04:19 PM

I do get that as well, but I dont think thats the problem. It seems to be an error with the blueprints messing up the movement axis. Im gonna do your thing because that was bugging me, and If It doesnt fix my other problem I'll let you know

avatar image ItsLightsaber09 Jul 24 '18 at 04:50 PM

So I made the object Ignore the player collision and I dont fly away anymore, but I found out the you only start to fly If you walk with the object in your collision box

avatar image DarkFearHunter Jul 24 '18 at 05:26 PM

Let me give you this. It is working for me so it might helpalt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question