x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS blueprint only PC build failed

Hi, I am using Win10 64bit, UE4.19.2 and I've been working with ARKit for a week now. I had a working ARKit project installed on iPhone 8 using UE4.19.2.Last week I installed the new UE4.20Preview to check out the new ARKIT 2.0 (new plane detection, better tracking, etc.). The certificate and the mobile provision were okay (GREEN) I launched the app and it asked for Remote Compiling. So I decided to go back to my old 4.19 project and continue working there, because I thought that 4.20 is Preview version and it's not working well, but the Remote Compiling error showed even in my old project where I was working all week with no problems. I can't get rid of the "Remote compiling requires a server name." error.

Here are the things I've tried using UE4.19.2:

  1. uninstalled all UnrealEngine versions that I had and installed only 4.19.2, again new certificates and provisions, but Remote Compiling still here.

  2. My project is BLUEPRINT ONLY using the built-in HandheldAR template no 3rd party plugins.(If you have 3rd party plugins they require Xcode compilation)

  3. I added a script in DefaultEngine.ini [/Script/IOSRuntimeSettings.IOSRuntimeSettings]

    bUseRSync=False

    This is suppose to disable remote building. It's enabled by default. It did not work.

  4. Tried to delete the following project folders Saved, Intermediate, Build and Binaries.

  5. Tried to delete the two rows in DefaultEngine.ini saw that in another thread, but all it does is resets BundleName and BundleDisplayName under Project Settings - Platforms - IOS - Bundle Information

    BundleName=ARFactory BundleDisplayName=ARFactory

  6. In another thread was mentioned that a clean Blueprint only iOS App will work on PC but the ARKit requires a Xcode Compilation on its own, so I made a new project without ARKIT to see if the plugin requires some Xcode compilation and is the cause of the error. Same result it wants the server again. So the problem is not in ARKit plugin because I was working with it a day ago and there is no difference if the project is with or without the plugin.

Product Version: UE 4.19
Tags:
more ▼

asked Jul 26 '18 at 06:40 AM in Packaging & Deployment

avatar image

MOSBozhidar
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question