x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Teleport in VR template doesn't work properly

Hi, I would like to solve teleporting problem which appears in my project. I created my level in basic first person template. After that I decided, that I would like to try migrate project to VR template. Everything was successful. I opened new project and tried VR experience in HTC VIVE. In that basic map called "Motion Controller Map". Teleporting was working properly. Than I just switched to mine level and teleport has been broken, like you can see on screenshot. Teleporting is working fine but just few centimetres before player. I can not chose destination of laser. Strange is, that I am using the same Motion controller pawn and BP_Motion Conrtoller from content browser. Of course in new level have been placed new motion controller pawn nad nav mesh bounds volume. Thank you for respond alt text

Product Version: UE 4.20
Tags:
more ▼

asked Jul 26 '18 at 12:46 PM in VR

avatar image

Antigone713
1 2 1

avatar image Chris Gallegos Nov 17 '18 at 07:46 AM

This has happened to me in the past when a skybox, or large terrain geometry, has a collision mesh.

If you are inside the mesh, the line trace for teleportation immediately returns because it is colliding with the mesh you are inside of. This causes the collision point to be right where your hand is, and that's where Unreal wants to teleport you to.

Try turning off collision on all your meshes (or at least the large ones), except for the floor. The arc should intersect the floor and that will determine where the teleport happens. If that doesn't fix the problem, then it's probably something else, but hopefully my answer will help someone else who has this problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Have you tried looking for collisions? Have you calculated paths, and if so, have you tried enabling path visualization to see the navigation mesh? (tap P on the keyboard).

more ▼

answered Oct 14 '18 at 10:00 PM

avatar image

Situx
6 1 1

avatar image ADemetriades Oct 22 '18 at 05:36 AM

I have exact same problem....

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question