x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ForceNoPrecomputedLighting Failed/Skipped Help

ForceNoPrecomputedLighting checked will fail unless lights are removed and that is built first. Paste them back in and rebuild to remove this fail/error

Product Version: UE 4.19
Tags:
more ▼

asked Jul 26 '18 at 02:16 PM in Rendering

avatar image

shadoow2213
13 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This is as designed. It's failing because the ForceNoProcomputedLighting is checked. That's its purpose. Since your lights are dynamic, there's no reason to build lighting because you have no static or stationary lights to build. So don't worry about building lighting if you're working with dynamic lights.

more ▼

answered Jul 26 '18 at 02:38 PM

avatar image

jkinz3
41 4 5

avatar image jkinz3 Jul 26 '18 at 02:42 PM

When you check ForceNoPreComputedLighting, it tells you to build once so that it removes all precomputed lighting. After that, you don't need to build again. If your game is super bright, then there are other issues at work. Launch the game in editor using the Standalone Game option and check the lighting. Check the map in the packaged game and make sure it's the same map you're using in editor.

avatar image shadoow2213 Jul 26 '18 at 02:44 PM

The standalone game has proper lighting, as does my editor. I only have one map. But when I package, the scene is super bright. When I check ForceNoPreComputedLighting, it tells me to build so I do. But it fails, it skips.

avatar image jkinz3 Jul 26 '18 at 02:46 PM

The build is supposed to fail because ForceNoPreComputedLighting is checked. You don't need to build the lighting anymore. Stop building the lighting and ignore it.

As for the bright light issue, i'd have to see images of the standalone game, the packaged game, and the in editor game.

avatar image shadoow2213 Jul 26 '18 at 03:28 PM

So with the build failing, Lightmaps are 0...

That is good!

avatar image jkinz3 Jul 26 '18 at 03:29 PM

check "ForceNoPrecomputedLighting" in the sublevel as well.

avatar image jkinz3 Jul 26 '18 at 03:31 PM

Check it in all sublevels you want dynamic lighting in.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question