x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

3D Widget input not working in UE 4.20.1

The input to a 3D button menu widget was working in 4.19 but having upgraded the project it is now not working.

I have an Actor blueprint with a widget component that uses a standard ui widget with a bunch of buttons on. The widget is set to receive hardware mouse input by default and the collision is UI.

The buttons are responding visually to me clicking them but not triggering the click event in the graph.

Seems strange that it just stopped receiving any input from the mouse in 4.20.1.

Has something changed?

Thanks for your help.

Product Version: UE 4.20
Tags:
more ▼

asked Jul 28 '18 at 07:48 PM in Blueprint Scripting

avatar image

3dev
96 2 6 7

avatar image iron_smith Aug 05 '18 at 08:00 PM

Hi, i was looking for an answer to this as I have a similar issue, where the widget is on an object in scene as a 3D menu. The buttons change colour when highlighted or pressed but they do not fire the action (load level etc) yet they did before i changed from 4.15, i also have an issue where the text is now appearing on the buttons as grey texture yet yellow on the widget page? Have you had any success in figuring out the issue with the buttons?

avatar image 3dev Aug 06 '18 at 06:36 PM
avatar image IronsmithStudios Aug 06 '18 at 06:41 PM

Hi, well I managed to fix it by simply swapping OnClick with OnPress lol. Even though it worked before, for some reason it just wouldn't work on a 3D object using OnClick?

avatar image 3dev Aug 07 '18 at 03:01 PM

Yes, that solved the issue for me too. Thank you.

Hopefully this bug will be fixed and we can use OnClicked as before.

This problem only affects the 3D widget as a 2D widget added to the viewport still works with the OnClicked event.

avatar image Kelheor Nov 05 '18 at 08:57 PM

Did you find a way to solve the same issue with TextBox? It also not reacts on widget interactor in shipped builds.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question