x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Does not work on Standalone, Works on Editor (PIE)

07-29-2018, 02:02 PM Hello, I have been working on an RPG for too long, it has no errors and I managed to make it as optimized as possible.

Today, when trying the standalone, an actor component isn't detected by the game anymore. It doesn't even launch the event begin play or the event tick while everything works properly in the PIE (-tried with delays -upgrading from UE4.19.2 to UE4.20 -ticked autoactivate -in the actor, on component activate shows that it's activated at the beginning of the game, however, still same problem -validating assets/fix up redirectors in folders/refreshing all nodes -recompiled every bp one by one -cleared the saved folder) (yesterday it was working fine, it did this after shutting down and turning on the pc today)

also, upon checking if "is valid" it displays for me that it's valid and it exists in both PIE and standalone but it seems like in standalone it is not working/ so probably desactivated. the attachment : The component event tick, shows in the PIE and doesn't show in the Standalone. alt text I worked on this for 1 year now, it's not really pleasing to experience this.. Thank you in advance, I'd appreciate all the help!

Product Version: UE 4.20
Tags:
more ▼

asked Jul 29 '18 at 03:56 PM in Blueprint Scripting

avatar image

Hirodemon
1 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Print Node is removed from ur build if your build set to shipping, as long as its development , you will see print messages .

Just set your build to Development or debug and you will see the print node just like inside the editor.

more ▼

answered Jul 29 '18 at 06:23 PM

avatar image

Omar Vector
445 16 16 29

avatar image Hirodemon Jul 29 '18 at 08:50 PM

It's already set to development. As I mentioned, there is absolutely no function working in the component, not only abaout printing, my character has this component, that makes him attack, dodge, throw spells..etc and all of that would work perfectly fine on editor but nothing would work on standalone

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question