x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.20.1 IOS ARTemplate Crashes after splash screen

I started the bare ARTemplate project and set it's world game mode to the BPARGameMode

I then set my provisioning profile and cert, and turned on automatic signing, the same thing i did with the third person template.

The ARTemplate crashes after the splash screen, the Third Person template does not crash.

I am using xcode 9.4.1 and ios 11.4.1

Anyone have this working?

Product Version: UE 4.20
Tags:
more ▼

asked Jul 30 '18 at 09:51 PM in Packaging & Deployment

avatar image

joessu
352 26 34 43

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

No Idea how but the plugins for ARKit were disabled. I thought I had enabled them! it works now but only the first launch, if i close and launch the app from the ipad, it doesnt work.

more ▼

answered Jul 30 '18 at 11:03 PM

avatar image

joessu
352 26 34 43

avatar image andyxor Aug 21 '18 at 11:53 AM

Ahhhhh, thanxx a million !! I doodled an hour to figure out why my app crashes all the time until i found this.

avatar image TheMayor Aug 23 '18 at 05:15 AM

In case anybody else is struggling with this, it kept crashing when I was trying to package the project when I had the ARKit plugin enabled, but figured out I wasn't running the latest XCode 10 beta. Fingers crossed, seems to be working now.

avatar image NasteX Sep 21 '18 at 02:12 PM

We also have the same problem... The latest Xcode doesnt fix anything, the app only opens to the splash screen and immediately after this it crashes.

avatar image andyxor Sep 21 '18 at 02:17 PM

It worked in my case BEFORE the update to ue 4.20.2 and ios12. Now the app prints an error like: "Failed to open descriptor file"

avatar image EmpireLion Sep 22 '18 at 04:02 AM

Same, ios12 seems to have broken my project as well. Shows the splash screen on iOS and then crashes.

avatar image HullzAngel Oct 17 '18 at 03:52 PM

You're a life saver. Thankfully I've only wasted about an hour wondering what was going on. Just updated the ARSample project to 4.20, and the plugin was disabled by default! Madness!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

the same happens to me

more ▼

answered Aug 10 '18 at 08:29 PM

avatar image

JuanF10
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

make sure you're running Xcode when you deploy

more ▼

answered Nov 12 '18 at 08:16 PM

avatar image

ArgonFx
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question